Unable to pair Blue Series switch to Zigbee2MQTT (Home Assistant)

Hey guys,

Today I wired up and attempted to pair a new Blue Series switch to Home Assistant using Z2M but it doesn’t seem to be working. I’ve paired many other switches prior to this without any real issues so I’m not sure what to do from here.

This is what happened:

  1. Switch wired up and powered on.
  2. Config + Upper button held for 20 seconds; LED starts flashing red.
  3. Permit Join enabled in Z2M.
  4. The switch is seen but says that it’s “unsupported” and the “Exposes” tab for the switch says that there’s nothing exposed.
  5. In Z2M, I click “Remove Device” to removed it.
  6. Go back to switch and try to pair again (step 2 + 3).
  7. Switch blinks red 3 times (sometimes it’ll be solid magenta), then just go solid blue (no blinking). Switch doesn’t show up in Z2M at all.

I’ve tried pairing it 5-6 times but it seems unwilling to.

Are there any other ways to reset the switch that might give a different result? My only other idea is to try restoring HA from a backup before I removed it but haven’t tried that yet.

Do you have the IEEE for the switch? And got the HA and Z2M versions? (I don’t use Z2M, but that may help check a couple things)

Does the switch never blink blue after you hold config+up to reset? When you release, which are you releasing first?

I tried recovering to an older HA backup but that didn’t help, in fact the 2nd last switch I included (which was removed w/ this backup recovery) now just stays solid blue when holding up + config… slightly different behaviour to the other one but in both cases unable to pair.

Where can I find the IEEE for the switches? I have the EUI and install code.

The switch never blinks blue, only solid blue. I’ve tried releasing config first, up button first, and both at the same time – same results.

The one I had paired successfully but now isn’t due to the backup recovery was 2.08 but the last one that was reading “unsupported” never gave me a version # in the UI.

1 Like

I believe it’s also listed as the EUI, the little piece of paper with the QR code that was in the box? (16 alphanumeric characters, like - 94:de:b8:01:df:03:ed:20)

For the reset you’ll want to release the config button first, but if that’s not working then I would recommend pulling the air gap tab. The LED bar should go dark when you pull it, wait a couple seconds and then push it back in. If it’s not paired, that should work.

Well that solved the original switch – thanks!

Unfortunately the one that was de-paired due to the HA backup recovery is still not able to pair. It just stays solid blue while trying to get it into pairing mode.

1 Like

That was the airgap that worked for the original switch?

For the one that isn’t pairing, do you have the date code from the paddle?

Yeah, pulling the airgap and putting it back put it into a blinking blue light state which was automatically picked up by HA.

I’ll have to check what the date code is on the paddle of the one that’s not pairing, can do it later.

It also started rapidly turning the light it’s connected to on and off very rapidly which I’ve never seen before – it just started doing this after pulling the airgap. I may also re-check the wiring just in case.

I don’t see any date code on the (white) paddle. I’ve removed it but there’s nothing on it as far as I can see.

The date code on the one that won’t connect now is 2212.

The IEEE is: 94:DE:B8:FF:FE:EC:13:04

1 Like

Solution #2 is here (it had local protection turned on):

1 Like