ZwaveJS2MQTT + LZW31-SN - any way to send a "simulated" paddle press?

I have LZW42 lights associated in a group with various LZW31-SN dimmers that have “ProtectionbySequence” on local protection, so that they instantly turn off and on when I am using the physical dimmer switch without cutting power.

I’d like to simulate the button presses in Home Assistant’s ZwaveJS2MQTT but I don’t know how exactly. Something to do with scenes and value 91? It’s mostly because the native light group HA feature is kind of slow, where bulbs turn off one at a time…

It sounds like you want to simply turn the switch on or off from HA. Take a look at the services light.turn_on and light.turn_off.

1 Like

This is a bit of the opposite way of handling this. What you are looking for is smart bulb mode.

Change the protection to off, then enable smart bulb mode 2. This will keep the load on 100% of the time (whether dimmer is on/off/dimmed). This is the recommended smart bulb setup.

I think that’s how it already is. The switch is associated with the bulbs and controls them quickly so the idea is to turn-on the switch so the bulbs react quicker than HA which is slow.

Multicast might help here, if it can be done for a light group

the idea is to turn-on the switch so the bulbs react quicker than HA which is slow.

Precisely. I tried out multicast and it’s better than standard HA light.toggle, and nearly as fast as group associations from the physical button. Unfortunately, multicast isn’t as reliable as pressing the button.

If I’m reading this right, you’d got association setup between the switch and bulbs and want to make use of the speed of that association when controlling the switch via your dashboard/automation/etc… It’s actually pretty simple.

In the config section of the dimmer just enable this.
[30-112-0-12-4] Association Behavior: Z-Wave Hub: Enabled

With that enabled, controlling the dimmer via HA will pass-through the association to your bulbs.

Thank you @MRobi – I would be thrilled if this method worked!

The issue there is that when controlling the LZW31-SN from Home Assistant, the dimmer, unlike my bulbs, ignores “transition” service data, in milliseconds, so the lights come on gradually instead of immediately.

Strangely, it also appears to ignore the configured device settings in ZWaveJS:

When I press the physical button, ZWaveJS2MQTT shows this in the debug report:

Node xx: value notification: 91-0-scene-002 0
2021-12-01Txx:xx:xx.xxxZ CNTRLR « [Node 0xx] received CentralScene notification {
"nodeId": xx,
"ccId": "Central Scene",
"ccCommand": "0x03",
"payload": "0x718002"
}

When I toggle the dimmer in Home Assistant, ZWaveJS2MQTT shows this in the debug report:

INFO ZWAVE: Node xx: value updated: 38-0-currentValue 0 => 0
INFO ZWAVE: Node xx: value updated: 38-0-targetValue 0 => 255

You know, you’re right. I turn on my master bathroom light quite often through a double tap on my master bedroom switch. I’ve been telling myself for weeks I need to change the ramp rate setting for instant on since it dims up and then back down which makes me stand there at the switch until it turns off. I just took a look and it’s already set to immediate and is ignoring that when called through zwave. Completely unrelated to association though. I’ll test a few others tomorrow and see if they do the same.