image not found img not found

Inovelli Community

2nd Gen Switch Device Association

I was hoping I could use one Switch to Automatically Associate to another Switch for a virtual 3-way. I have done this in the past with GE switch and supporting Handler in Smart Things, but don’t see an option to do this currently with yours.

Your wiring instructions mentions

“NOTE: For this to work, you will have to disable the internal relay on Switch #2. Then associate Switch #2 with Switch #1 via Z-Wave Association (we’ve created a SmartApp for SmartThings to help with this). DO NOT USE THIS IF YOU CANNOT ASSOCIATE YOUR SWITCHES”

Hey @lockout - great question!

Yes, you can associate the switches together using the Z-Wave Association tool located here: https://github.com/InovelliUSA/SmartThingsInovelli/blob/master/smartapps/z-waveat/zwave-association-tool.src/zwave-association-tool.groovy

Once installed, and you have the SmartApp opened, you should be able to associate the switches (choose Group 2).

Tagging @EricM_Inovelli just in case you run into any issues!

1 Like

@lockout to expound on what @Eric_Inovelli has already stated, the Z-Wave association tool is an easy and quick way to associate your Inovelli devices to other z-wave devices. In the app the “source” switch is usually the one that does not have a load and is to be used to control the other switch. The “destination” switch is carrying the load (connected to the light fixture). You simply select the devices as shown in the image below, save, and the association should be created.

This link appears to be for 45 lines of code for a smart app and I get an error when I attempt to Create New Association

On the github i see a second version of the codes with 138 lines of code? Am I to use this version instead?

here: https://github.com/InovelliUSA/SmartThingsInovelli/blob/master/smartapps/z-waveat/zwave-association.src/zwave-association.groovy

Hmmm… well that’s interesting. I just checked my IDE and I actually have them both installed and published.

However, in the app, it says, “Z-Wave Association Tool” so I assumed it was the first one I sent you. Maybe you need to have both installed.

Maybe @EricM_Inovelli can shed some light?

@lockout – try installing both and then use the Tool one (48 line) again. I’ve got it up and running on my setup here at the office.

Sorry for the confusion!

Hey @lockout, one is a child app. So both of them need to be installed. Technically only the “Tool” needs to be published, but it doesn’t hurt anything if you publish both. Just make sure you open the Tool app to set things up.

Well I got a bit further, but the association doesn’t seem to be working on my side…I was attempting to use a switch with a load to control a second switch with a load. Both 2nd Gen switches.

I can seem to get the association in the Tool to run now but the switches are not operating directly.

Use Case #1
Hallway Switch Controls both its Load and the Load on the Stairs Switch


If I understand my settings correctly if I hit the hallway light the stairs should work…

Use Case #2
Back Porch Switch Turns on Front porch Switch (On/Off)
Back Porch Switch Double Click Up Turns on (Front Porch, and 2 Outside Floods)
Back Porch Switch Double Click Down Turns Off (Front Porch, and 2 Outside Floods)

Using a GE 14291 switch I was able to do this directly with a custom DTH This works to control other z-wave Floods that I have, but it will not control your new switches.

21 = Front Porch Light (LZW30)
15 & 16 = Homeseer hs-fls100+

The Homeseer responds to the Association, but the LZW30 do not

Maybe I its user error on my side, but I can’t get any of the LZW30 or LZW30-SN to respond to Association with your tool or the custom DTH I use on the GE switch…

So it looks like the Hallway light does have an association for device “22” (see picture below). Is that the “Stairs Light” & what brand is it? Technically the Hallway Light should be able to control the Stairs Light.

For the double clicking to control the 3 lights you will have to setup a scene (not an association) if the Back Porch Switch is an Inovelli. You can do this with the Smart Lighting app (looks like you have that installed).

I might have one of the GE switches that I can test things out with. Is the model number 14291?

image

For the Hallway/Stair association its a LZW30(Hallway) to a LZW30-SN (Stairs)

When I look at the device info for the stairs the device seems to be added as a Z-Wave_Legacy_Non Secure does this make any difference. As I can be certain that the lights are not function as a linked

For the other case the GE 14291 DTH actually expose the double click as a separate button that you can associate too. Devices 15 & 16 response to the direct association while the Inovelli Switch(21) does not…

Ah yes, I believe that can make a difference. The Hallway light may be sending a secure basic set command that the stairs light can’t decrypt. The second scenario may be related to this as well. Can you post a screenshot for the GE switches (& Inovelli 21) so we can check their security?

I have started to process to test out a new Hub… The Hubitat unit just arrived and I have already migrated the GE Back Porch and Inovelli Front Porch and associated them successfully… Therefore I can’t get that screen shot…

Now on to the other 50 devices, along with automation… A bit lost right now in Hubitat, but hope to pick it up quickly…

2 Likes

@lockout, that is great! Yeah, there is a slight learning curve to Hubitat, but I have been really happy with it so far. It is extremely reliable and really fast.

1 Like

I’m running into a similar issue. I installed 2 on/off smart switches in a 3 way. One is a GE smart switch while the other is the inovelli red on/off switch. The GE is connected to the load and I’ve disabled both local and remote control for the inovelli. (As a side question, is disabling local control in the ST settings the exact same thing as disabling the relay by pressing the config button 8 times?)

I then tried associating the inovelli (source) to the GE (destination) using @EricM_Inovelli smartapp but it didn’t work. I changed the inovelli to use the GE device handler above and was able to get them connected and now it shows up under data in the graph in association group 2. However, it still doesn’t control the GE smart switch. Tapping up or down do not control the lights. The only way I can get it controlled is using the central scene which has a lag. Any idea why it won’t be working?

Also, do you guys plan to expose all the other 12 or so central scene commands as association groups also? That’s be really helpful for those of us using ST. With my GE switch, I had association groups for both single tap and double tap and they worked great. I also know you plan to expose association group 4 for the dimmer so adding the other ones shouldn’t be too much of work.

Thanks!

Yes, kind of – there’s actually two different ways to disable local control (remote and local). When you press the button 8x, it disables local control (ie: if you manually press the light switch). However, if you want remote control disabled, that can be done via the device handler in the settings (towards the bottom).

If you go into IDE, can you check to see if they are both showing up as the same, “networkSecurityLevel” (ie: ZWAVE_S0_DOWNGRADE or ZWAVE_S2_FAILED)?

The devices need to have the same networkSecurityLevel to be successfully associated with each other.

I believe @jtronicus brought this up in our thread about improving firmware: On/Off Switch (Red Series) | Project Lights Out (v2.0) which I think is an awesome idea. So, we’ll definitely look to add this feature and I’ve captured it at the top :slight_smile:

Famous last words lol – I said the same thing about the Dimmer Switch and here we are 6 months late lol.

Just to confirm, disabling local control (not remote control) via the device handler is the same as using the config to disable the relay? I have more switches to install and want to make sure it’s all the same.

The Inovelli says ZWAVE_S0_DOWNGRADE (my understanding is it uses S2 which isn’t supported by the ST hub) while the GE doesn’t have the “networkSecurityLevel” field. In raw description, my GE says " zw:L" which implies it’s not securely included. If that’s what’s stopping them from communicating, I’d rather disable the security for the Inovelli completely as I don’t really need light bulbs to be secure. Pls any idea on how to do that?

Thanks

EricM confirmed the following information for me in another post

Local Protection State Description
0 Unprotected - Device not protected, physical button presses work normally
1 Protection by Sequence - Internal relay disabled, but scene commands and config options still work. Physical buttons will still control any associated devices
2 No operation possible - Physical buttons do nothing
RF Protection State Description
0 Unprotected - device accepts and responds to RF commands
1 No RF control - runtime commands are ignored, but device still responds with status on requests
2 No RF response at all - Device will not even respond to status requests

Pressing the config button x8 is the same as toggling the Local Protection state between 0 and 1.

Thanks!

So the next question is then, does selecting “Disable Local Control” in the DTH change the Local Protection State to 1 and how can I check the current setting of the local protection State?

Okay, I’m now very confused as to if associations do work. I tried connecting another Inovelli red on/off to the inovelli and it made no difference. I used both @EricM_Inovelli’s smartapp and zwave tweaker. The other device shows up in both * associationGroup2: [0B, 14] and in zwtAssocGroupMembers but yet, it’s still not being controlled. I then tried associating 2 brand new red on/offs and same thing happened. It appeared to be part of the associationGroup2 but still isn’t being controlled with a turn on/off command.

Anyone know how to get association working with the on/off switches? I’m stumped

I dont use smartthings, so I am not really familiar with how you configure things for your personal setup, but I did see in your original post that you disabled remote control on the Inovelli switch? If disabling remote control is the same as changing the “RF Protection state” it might be the problem. I was under the impression that if the RF Protection state is set to something other than Unprotected, the switch will not send commands to other devices. If you enable remote control for that device, does it resolve the problem?

Thanks for trying to help. Unfortunately, that doesn’t fix it.