Adaptive Lightning Settings

It took me a while to figure out what to change to get the Adaptive Lightning add-on for Home Assistant to work with my Blue 2-1. It actually wasn’t much that needed to be changed.

I just needed to enable one setting that’s not part of the defaults:

detect_non_ha_changes: Detects and halts adaptations for non-light.turn_on state changes. Needs take_over_control enabled. Caution: Some lights might falsely indicate an ‘on’ state, which could result in lights turning on unexpectedly. Disable this feature if you encounter such issues.

I was having trouble before this was enabled that the lights would nearly always end up with manual control enabled. (Sometimes it seemed to work, though.)

I just wanted to share in case this helps anyone. I couldn’t seem to find anyone who posted something similar when I was troubleshooting.


Is your configuration dumb or smart bulbs? I’m working on this same problem and so far don’t have a solution to make the blue activate adaptive mode on the bound hue bulbs

If you’re using bound hue bulbs I would assume you’d also be adapting colour temp along with brightness? If so, you should be pointing the adaptive lighting at the bulbs, as the switch won’t have the ability to react to the color temp commands.

You’re spot on, the individual bulbs are easily working with both color and brightness by pointing directly at them. Now I want the blue switch to simply turn on the lights and AL to update the color and brightness.

I’ve found when the bulbs are off and start up behaviors are set to “on,” turning on the blue switch will turn on the lights like normal, and after some time the lights will update to AL. Ideally the adjustment would be immediate like when turning on the bulb from HA, but that solution isn’t obvious yet.


What’s your initial transition set to in your AL settings? And if they’re hue bulbs, they should be able to accept colour commands while off which should have the AL colour already being set before the light even turns on

I have both in different areas.

Reading other comments, though, that I’ve still got it wrong since I have AL set up for the switch instead to the smart bulbs. I’ll change that and hopefully it still works properly.

How do you set this up? My hue bulbs (with the HA adaptive lighting) turn on and then after 10 seconds or so adjust color

Thanks, all, for the discussion and helping me realize that I didn’t have it quite right yet.

So here’s what I found while trying some stuff with smart bulbs last night:

  • Everything works pretty well when AL is set up with just the switch, but it does not adjust the color. The brightness adjustment happens about a second after the lights turn on. (This is most of what I want anyway which is why I didn’t really notice, but the temperature change would be nice, too.)

  • When AL adjusts the Zigbee group (light.coordinator_bedroom_light) it works pretty well and adjusts the brightness & color (still after about a second), but the switch doesn’t show the adjusted brightness level. This seems like the right way to do it if there’s also a way to get the switch to show the right brightness level.

  • When AL adjusts two smart bulbs & not the switch that controls them, it works about the same (though I think AL suggests not to do this to reduce messaging).

  • When AL adjusts both the switch and the group, they seem to compete at times for which one is right. The lights don’t stay adjusted to the requested state. This makes sense because AL is setting that one of the two is under manual control and then comes back to adjust the other that wasn’t changed manually. This configuration just get confusing to use.

I’m out of ideas of how to get this all tied together properly now. I’m guessing it’s easier without the binding, but would like to keep the binding.

Do your switches properly show the brightness value for a bound Zigbee light or light group?

Also, I’m not sure if you’re using ZHA, but if so, did you enable the global option Enable enhanced light color/temperature transition from an off-state in order to get adjustment to happen while the lights are off? (I have Hue bulbs & would love to get this all nicely tied together.)

1 Like

First, I’d set your initial transition setting down to 0. This will make the effect take as quickly as possible.

When calling the service through automation, I do it setting the brightness and color temp from the adaptive lighting section.

          - service: light.turn_on
              entity_id: light.entrance_bulbs
              brightness_pct: >-
                {{ state_attr('switch.adaptive_lighting_front_entrance',
                'brightness_pct') | int(100) }}
              rgb_color: >-
                {{ state_attr('switch.adaptive_lighting_front_entrance',
                'rgb_color') }}

If you’re using group binding, I believe the switch LED should follow the bulb. I have my switches bound via groups in Z2M and that’s working for me.

Ok, I figured out something that will help for my situation. I’m using ZHA and have my switch bound to a group with two smart lights (Hue). To get Adaptive Lightning working, it seems that just binding to the Zigbee group (light.coordinator_bedroom_light) should be enough, but for whatever reason changing the brightness of that group (or the individual smart lights) doesn’t change the brightness of the switch they’re bound with.

So my work around:

Create a Home Assistant light group that includes the two smart lights and the smart switch. Have Adaptive Lightning adjust that instead.

I’m now getting proper temperature and brightness control via Adaptive Lightning. The LEDs on the Blue 2-1 are adjusting properly. And Adaptive Lightning uses this group to mark that manual control is enabled when the lights are adjusted via the switch or in Home Assistant.

I just point it to all of my end devices regardless of grouping/binding. It seems to like telling individual devices what to do.

Perhaps it causes un-needed congestion, but it works great in my installation.

I tried that as well, but as I noted above, my issue was the switch not showing the state change (brightness) when the bound lights were changed. Perhaps I have something set up wrong there.

Are you using ZHA?

Did you put the switch into the zigbee group it’s bound to? This is how I have it set up and al matches up with lights and switches that way (using z2m though)

I tried, but it didn’t seem to make a difference. I’ll try agin and report back.

I’m not sure if it matters, but for ZHA it only allows adding the switch as a device in the group on Endpoint 1 which it then lists as Identify, Light, And 41 more….

Hmm I use z2m so I’m not sure how zigbee groups work in zha but I would make sure all lights and switch are included in the group. Sorry I wish I could be more help

Here is how I handled this use case:

So, for setup:

  • Two Blue 2-1 switches on two different circuits.
  • Each circuit has two hue bulbs attached.
  • Zigbee group created for the four bulbs and the two switches.
  • Each switch is bound to the group via LevelControl and OnOff.
  • Adaptive Lighting targets Zigbee group.

With this setup, changes to on/off are replicated across as well as brightness and works when HA is down!

Now, when adding adaptive lighting into the mix, there are issues:

  1. Switches cause AL to go into manual mode based on how they’re setting brightness on the devices when turned on.
  2. Changing brightness at the switch does not set manual mode in AL.

My solution was to create an automation as such:

  1. When the switch entity goes from off to on, wait 1 second and then call the service to disable manual mode in AL.
  2. When specific buttons are used (in my case: hold up or down, double tap up or down), call serviced to enable manual mode on light with AL (no delay time needed).

I find this solution works well because if HA is down so is AL and my lights still function.

I’ve done this even in single switch to single smart bulb as it proved to work more reliably.

Thanks for sharing. I really wish this was more straightforward to set up. Your solution seems like a good one. I’ll keep in in mind as I add a few more switches and lights throughout the house. Any chance you can share your automation YAML?

This was a primary concern for me as well, so I like how your solution considers it.

My setup is as follow:


  • light.kitchen_dining
    • Switch: 11111111111111111111111111111111
    • Light: Single Smart Bulb
  • light.hallway:
    • Switch: 22222222222222222222222222222222
    • Light: Single Smart Bulb
    • Two different circuits
    • Switch: 33333333333333333333333333333333
    • Switch: 44444444444444444444444444444444
    • Light: Switch 1 Smart Bulb 1
    • Light: Switch 1 Smart Bulb 2
    • Light: Switch 2 Smart Bulb 1
    • Light: Switch 2 Smart Bulb 2

Breaking it down:

  • When a zigbee group light is turned on at switch or config is tripple clicked:
    • Wait 1 second.
    • Apply Adaptive Lighting to group using default transition time.
    • Wait transition time.
    • Disable manual mode on group.
  • When a switch has Up or Down held or double pressed, set manual mode.