Blue Series 2-1 Switch - Enhancements/Bugs Thread

Well, by “sort of” I mean that in the smart bulb mode the load defaults to on all the time. In this mode I gain the ability to use the single up and single down presses independent of the light output but the light output is always on. What I would prefer is to still have control of the light output I just don’t want it to always be associated with a local button press.

To say it another more home assistant way, I would like the load output of the switch to be an entity and the button presses to be an entity. Both independently accessible within home assistant (or your chosen hub).

It’s surprising hard to describe clearly unfortunately.



Regarding the Reconfigure button - Not in my experience, but it certainly doesn’t hurt if you want to try it?

For the button presses, like Bry mentioned, you could also use Local Protection which will disable direct control of the load but still sends button press events when you press/hold the paddle or config buttons. With the hub, it’s just down to the automations you set and what you want them to do. If you lost the hub then by default you wouldn’t have control of the load, however you can disable local control via a button combo on the switch and then you’d have control of the load output again.

Use Disable Local Control. The switch will remain at whatever on/off status and dim level you set via the hub and paddle presses will not affect that. You retain full control via the hub.

1 Like

Thanks Bry. This is exactly what I was looking for. As I suspected, I just wasn’t looking in the right place, y’all already had it covered. The option is called “Local Protection” though. Switching this on accomplishes what I was hoping for, disconnecting local control of the load output from an up/down press of the paddle. Awesomeness…

I am beginning to really really like these switches. They are basically a one to one replacement for my Vantage Controls switches that I have been waiting for ever since I started using Home Assistant. They are allowing me to replace the Vantage system (20 years old) without losing any functionality. Reliability is still an unknown but I have my fingers crossed. If they have half the longevity of my Vantage system components I’ll be super happy.

Again, Thanks so much for such a quick response!

Big Pete…

1 Like

Glad you figured it out. There are so many different configuration combinations that it is hard to know if something is possible or not. Even I have to think hard sometimes to navigate all the different scenarios.

I may have come across a bug. But it may be on the bulb side too.

Using z2m, blue series bound to ikea bulbs. Binding works fine. LED tracks with the bulb brightness. Everything is good on that front. But when I physically turn the switch off, the next time I turn it on it will be set to 1%. Default level local and remote both set to 255 which is previous level.

Even though I have ramp rate set to 0 on the switch, and transition set to 0 on the bulbs, when I use binding the bulbs always transition down over about 3s. So what I think is happening is the switch is detecting the level of the bulb as it transitions down to off and receiving a brightness level of 1% before it turns off. So when it’s turning on to previous it’s at 1%.

This sounds like an issue we created a new configuration option for. Can you enable parameter 125 and test it out?

parameter125 : [
number: 125,
name: “Binding Off-to-On Sync Level”,
description: “Send Move_To_Level using Default Level with Off/On to bound devices”,
range: [“0”:“Disabled (default)”,“1”:“Enabled”],
default: 0,
size: 1,
type: “enum”,
value: null

Enabled and now they turn on at 100% regardless of previous level. I’m going to pick up some better bulbs. This could be a quirk with the Ikea bulb.

Even if default level local (possibly remote I am not sure) is set to something else?

They’re both at 255

I got around to testing this and I think it may be the bulbs you are using. My experience was that when I enabled P125 the bulbs would turn to default level local when controlled locally. Remotely the bulbs would return to their previous level, but I believe the z2m converter is doing this on its own. That might be able to be optimized though but I haven’t had time to look into it.