Blue Series 2-1 Switch - Enhancements/Bugs Thread

@mamber I was poking around in my hubitat logs again and noticed another odd warn message for these.

dev:19582023-11-17 08:02:30.063 PMwarnMaster Bedroom Door Switch Unknown Cluster(Cluster:0x8001) catchall: 0000 8001 00 00 0040 00 09C0 00 00 0000 00 00 8A00CDCE05FEFF693494C009

It seems that all 6 of my devices have done that a few times in the past couple of days. Any chance you know what may cause that? I am turning on debug logging to see if I can catch anything else in the meantime.

I suggest turning off Debug logging unless specifically asked by a developer (or me). It generates a ton of data that is mostly meaningless except when troubleshooting a repeatable error. Leaving it on continuously overloads the hub and makes it very hard to read the other relevant info in the logs

If you want to see more than Info logs, Try playing with Trace logging instead of Debug

Did this ever get discussed further? I would love to see double, triple, quadruple, quintuple held events along with the press events. You can use it for color cycling as well as brightness control. Say you have a room with dumb lights and smart lights. You can have the single presses actuate the relay which controls the dumb lights, then the double presses control other smart lights, but double hold up could increase the brightness of the smart lights, and double hold down, could decrease. Of course this could be expanded to any number of actions.

Basically extending this table to include tap and hold, double tap and hold, triple tap and hold, etc over just tap x times and hold/release events.

Action Button # Event Code
Tap Up on Light Paddle 1x 1 Pushed 0x0200
Tap Up on Light Paddle 2x 2 Pushed 0x0203
Tap Up on Light Paddle 3x 3 Pushed 0x0204
Tap Up on Light Paddle 4x 4 Pushed 0x0205
Tap Up on Light Paddle 5x 5 Pushed 0x0206
Hold Up on Light Paddle 6 Pushed 0x0202
Release Up on Light Paddle 7 Pushed 0x0201
Tap Down on Light Paddle 1x 1 Held 0x0100
Tap Down on Light Paddle 2x 2 Held 0x0103
Tap Down on Light Paddle 3x 3 Held 0x0104
Tap Down on Light Paddle 4x 4 Held 0x0105
Tap Down on Light Paddle 5x 5 Held 0x0106
Hold Down on Light Paddle 6 Held 0x0102
Release Down on Light Paddle 7 Held 0x0101
Tap Config Button 1x 8 Pushed 0x0300
Tap Config Button 2x 9 Pushed 0x0303
Tap Config Button 3x 10 Pushed 0x0304
Tap Config Button 4x 11 Pushed 0x0305
Tap Config Button 5x 12 Pushed 0x0306
Hold Config Button 13 Pushed 0x0302
Release Config Button 14 Pushed 0x0301

Is it true that when using zigbee bindings with smart bulbs, the Blue 2-1 does not send any ramp rate to the bulbs when telling them to turn on/off? (as indicated in this thread for the Z-Wave switches)

If that’s true, please consider it a feature request! I would expect the ramp rate parameters to be applied to smart bulbs when using Zigbee bindings, too! :bulb:

2 Likes

This really would be a great feature if possible

I tried searching this thread, is there any request in place or progress made toward enabling scene control from aux switches?

i.e. triggering scene via double tap on an aux switch connected to a blue series 2-1?

Thanks

This has worked since delivery of the switches. Been using double taps from an aux switches for over a year.

4 Likes

I would love to know if this was ever considered.
I went to https://github.com/InovelliUSA/Firmware but I couldn’t find issue #134.

Yep it was added; not sure which firmware but its there.

1 Like

This is awesome !!! My family will love it.
I’m using Home Assistant ZHA so I will look for it in there. Thanks a bunch.

It looks like 2x Tap Down to Level was added on 2.12.

Based on this post and the information displayed in HA (ZHA), I believe I have 2.14:

Blue Series 2-1 Firmware Changelog | VZM31-SN
April 11, 2023 / v2.14 / 0x0102020E

image

However, I don’t see that option.
I do see the a “Double tap full brightness” option, which appears twice and is disabled:

image
image

image

This is from one on 2.15, but you may just need to remove/readd the switch to clean up and refresh those options?

1 Like

Thanks, I’m hopping there is a better way. Removing and adding back over 30 switches is a lot of work, not to mention I can only imagine I will have to re-do automations as well. There is gotta be another way :frowning_face:

If you want to be extra safe, you can copy the entity names, but Zigbee should remember the device when it comes back in so your automations should be untouched. Also when you hit remove from the UI the switch goes back into pairing mode so you can just remove/readd pretty quickly. Definitely can appreciate that adds up across over 30 switches though.

1 Like

I think the way zha works that it has to be re-added. During the interview it goes through the available options and adds the entity for it. I’m not aware of a way to do it other than this.

Like @chack mentioned though if you add it back with the same name it should be in all your automations. Maybe try it one one device and see how it goes. Let us know if it works the way we are thinking. Also, if you remove and readd (without factory reset) it should keep all its configuration settings (except for maybe bindings which may need to be redone).

1 Like

I can confirm it works as described.
I removed one swtich, added it back with the same name, the automation and device settings were all kept.

To make sure I understood it:
Every time you add or remove a parameter or make a change that impacts the user interface I will have to do this for all switches again? That kinda sucks :frowning_with_open_mouth:

These were my exact steps by the way:

  • Copy device name (ctrl+c - just to be safe)
  • Remove in the Remove button (HA user interface)
  • Device went into pairing mode (flashing LED bar)
  • In HA, click Add Device
  • Device was found with a default name
  • Paste name (ctrl+v)
  • Select same area as before and leave the add device screen
    I
1 Like

I think this seems to be the case. On the flipside, if you don’t need it through the UI on the device page, you’ll still have access to the parameters through automations or managing them directly, it just takes a couple steps. If a parameter is removed you can disable/hide it on the device page, but that’s still a manual step.

1 Like

This may or may not have already been requested but my eyes where going cross eyed searching for this particular feature request. Or maybe it’s possible and I just haven’t discovered the setting yet.

I would like to completely separate the switch (button presses) from the load control. I understand that you can put the switch into “smart bulb” mode which “sort of” accomplishes this. That said I would like to be able to press buttons on the switch without it effecting the load attached to the switch.

I am coming over from a 20+ year old Vantage lighting system and this is how every one of their dimmers worked. It is incredibly useful allowing independent control of the load from local button presses. I understand that this would create a situation where if communication with the hub failed then you would lose the ability to control the local load directly from the switch. This situation was avoided in the Vantage system dimmers by a fallback local control mode when it lost communication with the system controller (hub).

Is this something that can be accomplished in a future firmware update or at all?

Thanks!

Big Pete…

Would using the “reconfigure” button work instead of manually removing and adding back?›

image

That is exactly what the Smart Bulb Mode (if you want to switch to always put out 100%) or Disable Local Control will do. Why do you say “sort of”? What isn’t working as you would expect using one of those two modes?