Blue Series Fan Switch Firmware Changelog | VZM35-SN

new firmware is working great. only problem is the levels default to 25/50/100. previously they were 33/66/100. not sure if it matters. i don’t notice a difference. i did try to change the defaults using p131 and p132, but the levels didn’t change.

This would be a problem for many external automation systems, especially those that work with HomeKit. Low/Medium/High are commonly mapped to 33/66/100 and not 25/50/100 - you’d basically be unable to set the fan to “low” with these defaults, as it would round to the next interval.

Also, many AC ceiling fan motors are stepped at 33/66/100, so they’d be underpowered if these values were actually sent. You’ll get weird noises and premature motor wear from that

The actual AC output levels are determined by the hardware (capacitors) inside the the switch. And these are fixed at 3 different levels (low/medium/high). The numeric levels exist as ranges in the software/firmware.

A level in the range of 1-33 will power the load via the low speed capacitor.
A level in the range of 34-66 will power the load via the med speed capacitor.
A level in the range of 67-100 will power the load at 100% of the line.

In other words, setting level 25 has the same effect on the load terminal as setting it to 33.

3 Likes

Oh! Good to know. I had other (different brand) switches that didn’t work this way and caused me tons of problems. This is a better design, though it might still require automation updates/code changes if you used specific values in them.

Do you mean when you tell the fan to go to low, medium, high in Hubitat or where are you noticing it? Like @mamber mentioned the actual numbers don’t matter too much, but I am curious to find out where the change came from.

When I cycle the speeds using the paddle the level shows as 25/50/100 on the device page. When i set the speed to low, medium, high on the device page the level shows as 33/66/100. The fan speed appears to be the same using both methods.

I performed a reset, but the result is the same. No speed/mode status in HA using Z2M.

@tasinclair4 Did you test this on firmware 1.05 as well or just 1.06? I am able to see the speed change, but I think there may be a problem related to the level thing reported by @Shadrach. The switch will jump to medium, but HA won’t report it right away because it hasn’t reached the threshold z2m is expecting. I think from the z2m converter it is not showing the speed change to high until the level reports at 254. So there is a gap between when the switch goes into high mode and when z2m reports it has changed.

const fanModes = { low: 2, medium: 85, high: 254, on: 255 };

I am testing the levels and I am not sure if they have changed, but I am seeing:

1-33 (1-85) Low
34-66 (86-169) Medium
67-99 (170-254) High

First column is % and second is the Zigbee value.

So if you change the parameter “Default Level” to like 90
Double tap up to 254
Double tap down to 50

Also, change single tap behavior to 0 (or old).

I think he may be referring to the new EP3 levels (P131-P133) when P130 is enabled. Not sure how those got to be 25%/50%/100% when the local levels have been 33/66/99 since day one. I debated updating the Hubitat driver to override those defaults (via the ‘default’ field in configParams). But it ultimately needs to be a firmware update.

1 Like

did erics suggestion work for you? I’m having same issue where LED refuses to turn off. Actually i was able to replicate your results. Increasing worked fine, setting to 0 reset it back to the default. resetting did not resolve.

On the Z2M side we should probably. Change the level mapper to interact with the fan control cluster instead of the level control. That will avoid all of this exact level nonsense.

I wanted to do that on the canopy module adapter, but got side tracked.

It’s ultimately going to make it better, as you need to deal with Smart mode as well, which if I recall is mapped to like raw level 2 or something.

Was 1.06 pulled? No longer coming up with updates on Z2M

1 Like

@EricM_Inovelli and @davinci515

Unfortunately, it did not work. The LEDs will not set to zero when off or on. My Blue Series Fans have done this since I first started installing them. I’ve had a couple of shipments (some of the original batch).

1 Like

There have been two switches that are not reporting their mfg and model info after a factory reset on firmware 1.06 and I am trying to get info from the engineer on why this is happening. They are on Chinese holiday of course so the timing isn’t good.

I have paused the update for z2m users and am recommending that users hold off on updating and to not do a factory reset if they have updated.

1 Like

Is this the update that will fix the keep alive for the 2-1 blues like it did for the fans?

@EricM_Inovelli I attempted to update to 1.06 a couple of days ago and noticed the same thing. No mfg or model info. Now without any of that being reported what is the best way to roll back to 1.04? I can’t ota the updates like I did before based on those.

That will be 2.17 or 2.18 for the 2-1, but yes, it will have the fix.

@xorso which hub are you using? There is a trick on z2m that we can do to update the fw. Hubitat you can choose the fan driver and assign it manually.

2 Likes

Any idea when those firmware’s might be ready for beta? Itching to get my blues back online

@EricM_Inovelli I am now using ZHA. I can switch to z2m if I need too.