image not found img not found

Inovelli Community

Dimmer Switch Powers Off (even when switch is disabled)

My setup
Dimmer Switch: LZW31-SN
Bulbs: 4 x LZW42 (Inovelli’s own RGBW bulbs)
Bypass: The recommended Aeotec Nano Dimmer Module
Hub: Home Assistant 3.10 with Supervisor 200 running on Hass.IO
USB Dongle: Z-Wave (Sigma Designs) UZB Z-Wave USB Adapter (aka Nortec Linear HUSBZB-1)

All 4 bulbs are associated to the dimmer in groups 2: Basic Set, 3:Switch Multilevel Set and 4:Switch Multilevel Start/Stop.

The switch and the bulbs have been included in the network without security, though I tried with security as well. I re-added them without security to help keep everything nimble.

I know there is a lot of talk about this issue, but I can’t seem to get past it. I have the internal relay disabled (8x tap Config Button flashes red 3x). I have reset config parameters 21:Power Type to Neutral then back to Non Neutral and 22:Switch Type to 3-Way Toggle then back to Load Only. I have also tried setting the setting 5:Minimum Level to 45 which, as I understand, should not be needed since I’m only powering smart bulbs.

With all that done, when I turn off the switch either by tapping down on the paddle or sending a power off command, the power gets cut to the bulbs. I have tested this by putting a “dumb” dimmable bulb in one of the sockets so I would expect that the associated bulbs would all turn off but the dumb bulb would still have power and not turn off.

Are there some commands I can send to change it so that the switch actually stays on and only commands are sent? When it turns off I can’t control the bulbs individually and my network has to adjust routing accordingly which can take some time.

Maybe this is should be another topic, but I’m wondering if there are configuration settings on the bulbs that disable their ability to route so that my network doesn’t rely on them. I have plenty of other adjacent powered devices that can do this work.

An easy solution is to connect the line/load wires together in the box and then install the switch with nothing hooked to the load terminal. This will send power constantly to the light and you can use zwave association (group 2 and 4 only) from the switch to control the bulbs.

Thanks @MRobi. That might be what I have to do if I can’t do it with configuration settings. Do we know if this is “as designed” or if it is not working as intended (ie. the “disable relay” feature doesn’t actually disable the relay)? If it’s the latter then maybe I need to put in a support ticket so that it can be tracked. If the former then I guess I’ll have to live with it and rewire accordingly.

I’m not too familiar with node group associations, but I’m curious why rewiring as you specified would need group 3 dissociated. Wouldn’t Switch Multilevel Set be the right group to use when setting a predefined Scene? AFAIK I can’t currently set scenes from the switch directly to the bulbs, but whenever the “advanced features” get approved and merged in Home Assistant I would think that’s when that group would be used. Again, see my disclaimer above. I might be way off base as far as how all that works.

Take a look at the end of this thread. Same issue with the power being cut to the bulbs when the relay is disabled, but in @richthetech 's case, it was random and not when you toggle the switch. He believes he resolved the problem by upgrading to the lastest driver. Might be worth a shot.

Thanks @Bry, but unfortunately I’m not using Hubitat or Smartthings (using Home Assistant), so those drivers won’t help me. Regardless, maybe I can look at the code for the drivers and see what’s changed to make it work… here’s to hoping.

Disabling the relay by pressing config button x8 should prevent the power from being cut when you press the physical buttons on the switch. However, this does not prevent you from powering off the switch remotely.

A couple things I recommend checking:

  • Pressing config x8 is the same as changing the Protection setting between “Unprotected” and “Protection by Sequence.” If the config x8 is not working, I recommend checking/setting the setting in your Zwave control panel in HA
  • Your original post indicates you have the Black series dimmer (LZW31). However, if you actually have the Red series, I recommend double-checking to make sure any scenes you have set up are correct. If the switch is sending a scene to HA, and you have an automation set up based on that scene, you might have accidentally added an Action to turn off the switch. Since disabling the relay doesnt prevent the light from being turned off remotely, the symptoms could look exactly like what you are experiencing.
  • I am not sure if this is even possible, but make sure you didnt accidentally associate the switch with itself.
  • Since you have the bulbs associated with the switch directly, you could try shutting down HA to see if you still experience issues. It might at least help pinpoint the root cause.

To my knowledge, there is no way to turn off routing on the bulbs. This shouldnt really be an issue though. I believe devices always prefer to communicate directly (non-routed) if possible, and will only route a signal if direct communication is not available. There is a lot of interesting (but technical) information here about how the routing protocol works.

Thanks @jtronicus, all that is helpful and I’ve been wondering what the Node Protection does.

Just to confirm, Unprotected would mean that the internal switch is enabled and Protection By Sequence means that the switch is disabled? In HA, there is a third option No Operation Possible. I fiddled with that but didn’t get any different results.

You are correct, I do have the red series (I got the holiday pack).

While I do have a couple of scenes set up in HA, they’re only triggered manually right now.

I just double checked and the switch is only associated with the 4 Inovelli bulbs in groups 2,3 and 4. It is associated with group 1 to the hub (which is the case for all nodes).

I shut down Home Assistant and gave it a try. Dimming and powering off still worked, but it then occurred to me that this wasn’t really testing that it was dimming due to commands. It could have been due to the dimmer actually changing power levels. But it wasn’t. I changed out one of the bulbs for an incandescent and tried dimming and on/off and that bulb didn’t change. This confirms what you said first about the setting not preventing remote power off. THIS IS PROGRESS! Now that I know that I can count on my lights still having power when I use the switch to turn them off, I can start looking into how to configure the light entity to not allow power off. I’m pretty confident that I’ll be able to do that with either an existing or a custom Entity in Home Assistant. THANK YOU!

Thanks for the 411 on routing, too. I’ve been looking for a good explanation of that!

Here is what the Protection values do:

Value Function
Unprotected All features unlocked
Protection by Sequence Internal relay disabled, but scenes and remote operation still works
No Operation Possible Internal relay disabled AND scenes/remote operation disabled. Pressing config x8 also does nothing