Firmware v1.19 (Beta) | LZW30 | Switch - Black Series (Gen 2)

Thanks guys!

do you happen to have a link i could use to update my switch with the hubitat tool

Hey @adriang809 - all files can be found here:

Just search the model number and you should be good!

ive got that one but all i can do with it is download it… idk how to proceed on using it with the firmware updater tool…

If you right click on the firmware file and select, “copy URL”, it will give you the URL and you can paste that in the Hubitat tool

gotcha… thanks

1 Like

@EricM_Inovelli With the impending release of Hubitat version 2.2.3, does the firmware for the switches/dimmers need any updating to work/pair correctly?

I’ve been updating a bunch of my LZW30’s from 1.11 (using the secondary controller method with PC Controller v5.39 with a SmartThings v3 hub as primary). All but one of them flashed successfully (as did my LZW30-SN’s and Target 0 on my LZW31s, but that’s a different thread…).

For the switch in question, the first time I tried flashing the switch, I mistakenly allowed the PC laptop to go to sleep in the middle of the flash. By the time I realized this, the flash process was stuck: PC Controller was not able to send any further packets, and after several minutes I had to abort the process.

The switch still shows fw 1.11 in PC Controller. Further attempts to flash the switch end after a few seconds with no packets sent. At this point, the switch becomes unresponsive and will not respond to Node Info commands from the PC Controller, as seen below, and furthermore is unresponsive to physical button presses until air-gapped.

Annotation 2020-08-08b

After being air-gapped, the switch seems to function correctly, except that any further attempts to flash the switch again result in an unresponsive switch.

It seems something in the switch got confused after the failed flash; maybe the partial upload hasn’t been deleted from wherever the chip buffers new firmware during the flash process. However, multiple iterations of air-gap-and-try-again (with a restart of the PC Controller software between each), with the PC closer to the switch have failed to resolve the problem, as has excluding/re-including and factory-resetting (20sec press on the config button) the switch?

@EricM_Inovelli is there some method, beyond what I have tried above to get the chip to forget the bad upload so I can flash the new firmware?

As far as I know you shouldn’t have to do anything with the device or driver.

@jmason888 it sounds like you have tried everything as far as what can be done in your setup. Maybe try escluding your z-stick from being a secondary and try to add the Inovelli into its own network with the controller and try from there. I have aborted many firmware updates and have never seen this so my guess is that you can get it going again.

1 Like

Thank you @EricM_Inovelli, that did it. I guess I’ll chalk this one up to some gremlins in my Z-Wave mesh :wink:! Literally every other switch flashed fine (some slowly, some quickly) with the z-stick as secondary. For this one, it needed to be on a separate mesh with the z-stick as primary, and it needed me to sit with the laptop/z-stick right next to the switch, and it still took more than 20 minutes.

I guess this switch was tired of social distancing!!! But it worked… and I have 11 switches to flash (I’d have more if the Red Series hadn’t gone out of stock), and I’m glad I only had to dance the “exclude, include, and rebuild all my automations” dance with one of them.

1 Like

What’s in the new 1.20 & 1.21-beta firmwares that were published

Also wondering what changes are in 1.20 and 1.21 Beta @EricM_Inovelli

@mrvjtod @mraz.camren

1.20 has a change that optimizes z-wave exclusion during mass production. This change is for quality testing after assembly.

1.21 has similar S2 inclusion optimizations for 700 series hubs that are in the dimmer v1.48. S2 inclusion works fine on the switch though so this update really doesn’t change anything. It was just to bring the code up to date between the dimmer and switch.


I was trying to install some switches in the new house before having any network and I set a couple up with auto off timers set to 1800s and 7200s. The idea was to delay timer off some lights when I leave the new house in the dark.

But, the switch parameters all reset to default when excluded from the network. WHY? I don’t want them left connected as dead nodes on my home automation in my current residence until the new house is finished and I move in.

I believe Z Wave Alliance protocols makes the switch factory reset when excluded from a network.

1 Like

Yeah, that is part of the Z-Wave 500 SDK. You would have to connect them to a different controller & set the configuration parameters and not exclude them afterwards.

How do I tell what firmware is on my switches? I have a Hubitat C5.


If you’re using the Hubitat drivers it says the firmware version on the device page.

Mine doesn’t list anything except Switch: off

Which driver is assigned?