Firmware v1.36 (Beta) | LZW36 | Fan + Light - Red Series

Yeah, for some reason I thought I was supposed to be using S0, which was throwing everything off. Also, I thought that the updater at the top is the linked page was supposed to be the binary updater. But no, it’s buried further down in the thread.

@EricM_Inovelli following all these directions, finding the correct version of the Firmware Updater and finding the correct URL to copy for firmware I was able to update my 1st Fan Switch.

What I learned about this process is that it sucks. I had created Rules, but when I excluded, then included again to set NO SECURITY to get the firmware applied, AND then excluded and included to set the security back to S2, the Rules were broken. I had to fix them. I have more switches to upgrade the firmware on. Which means my rules, scenes, grouping will break. Is there a step or process I am missing to avoid the hassle of having to rebuild everything for each device when a firmware needs to be applied?

Also, how important is the S2, S0 security? Is it ONLY used for the paring process and when paired always uses the AES128 encryption regardless of what security level is used? Is the issue with the firmware updater not able to work with the S2, S0 security yet?

Even if I used the other process with a Windows PC, usb Z-wave stick, and the Silicon Labs tool, I will have to exclude and include it which presents the same problem with Hubitat rules, scenes, etc.

Would love to hear your thoughts and best practices for this process.


The upgrade process has been different on the C-7. From what I have heard the C-7 can only perform updates when security wasn’t used during pairing. Hopefully @bcopeland can clarify or provide info on whether a S0/S2 version will be created. Before the C-7 you could usually do the update in-place and keep your rules etc. as is.

As far as the importance of S0/S2, that is debatable. Z-Wave runs on its own network which already provides quite a bit of security on its own. I prefer not to use S0 as it consumes a lot more bandwidth than non-secure / S2. I use S2 when available but I’m not very worried about issues from including non-secure.

Alright… jumping threads here, trying to keep the questions in the most relevant threat. I got past my basic Hubitat Firmware updating questions… I got the “sleep device” error but then realized S0/S2 wasn’t my problem since I have a C-5, so I just tried again and it SEEMED like it worked… If I click get version report it gives me this:

However, when I switch back the parent driver it still says 1.31? Refesh button doesn’t seem to do anything. Is it really still 1.31? Do I have to delete the whole device and re-add it (would prefer not to have to re-setup eveyrthing that uses it…) OR is it just being stupid about refreshing the displayed parameter and I just ignore that and I’m good?

Thanks! Almost there! I volunteer to update your tutorial pages for this once I get through this all!! :slight_smile:

Try clearing your cache, I have had to do that on multiple devices.

I use Homeseer too… So does that mean until Homeseer adopts/supports .GLB files I will not be able to do any updates? New to Inovelli. :slight_smile:

I have asked homeseer to support .gbl files and I do not think that is going to happen anytime soon.

Inovelli seems to be hubitat centric. I don’t really understand that as I think they have a small percentage of the market compared to homeseer, but that does seem to be the case. This is not a holy war, I like the hubitat platform and if i stared over it might be what i would use, but i’m not going to start over. :slight_smile:

FWIW, i have had zero issues with the firmware that shipped on the devices.


Thanks for the response! Impressive!!

I did hook up 2 of my Inovelli items 9 ordered several and a fan switch to try.

Both DO NOT (both new RED Series) turn off the light/device off 100%. I thought I ordered a dimmer which was a switch, I hooked it up to my lights that did not turn off completely… very dim but still on. I moved this to my Fan ordered a dimmer and same thing.

What am I missing or doing wrong with these devices. The majority of my home is z wave GE and I have not recognized these issues.

Do not turn off by HomeSeer controller or manually at the switch.

I like your devices better!

@pbennett If you click on “Save Preferences” when our driver is being used it will query the device to see what firmware version it is using.

@DaleRS Until Homeseer supports gbl you can only update the firmware by using software such as PC Controller. As for the lights not turning off 100% what is the type of bulb and wattage?

I just received my 3rd LZ36 (love the first two). After a successful physical install and zwave pairing, it stopped working the next morning, just like one of the other two. So I figured I’d update the firmware from 1.31 to 1.36. For whatever reason, the update is going painfully slowly. I am using the binary z-wave updater and this gbl file. After 2-3 hours with the update still in progress (%'s moving up very slowly), I noticed a bunch of errors in the log. So, I decided to start from scratch, but this time I moved the C5 hub right next to the switch in question, and re-initiated the firmware update. It’s been 15 mins, and I’m still at 0%. I’ve done this successfully twice–can’t figure out what I’m doing wrong. Any ideas?

is there any status of perhaps a new FW coming out, I am still having issues with my switches.


I also still have issues with my fan/light switch disconnecting from the canopy module. In fact, it is getting worse. I’ve had it happen twice in the last 24 hours.

Using 1.36 firmware and 2020-10-01 driver.

I noticed project Rock Out is supposed to have a way to sync the notification LEDs. Any chance that option might come to the fan/light switch?

Is it telling you to wake your sleepy device or anything? I’ve had this happen a few times with my C5.

There shouldn’t be any more issues with disconnections as it was resolved in this release :frowning: – can we swap it out for you to see if it’s just a faulty switch?

I’ll defer to @EricM_Inovelli on this one. Great question!

Yes, it does for like 10 seconds, then it seems to “take”. I tried the firmware update like 8 more times, and it finally worked. All seems okay now. Not sure what was going on.

I’m supposed to be on the list for a new canopy module anyway, because I have the issue where the brightness flashes bright or dim, every few minutes.

Here’s the deal… I have two switches that are doing odd things that are not the same between two.

One just won’t report the status to my hub anymore 90% of the time.

The other switch sometimes just stops responding at all. Or the blue light turns on but the fan light does not!

I’m so furious at how many issues these switches are having, I just don’t want to keep them pulling them out and putting them back in and repairing them. And then having to fix all my automations because of it.


Two of my three LZW36’s will not upgrade to the new c1.36 firmware on my C7 Hubitat hub platform version Tonight pulling the LZW36’s air gap took too long to reset so I had to get a ladder out to remove the fan’s glass light shroud then unscrew the metal cover to pull apart the harness to the light module so I could sleep in the room. When is there going to be a fix for the inovelli LZW36s with c1.31 firmware? My emails to Eric have not been answered since his response of 11/23 saying hang in there we will figure it out.

Hubitat has created a firmware updater App. Have you tried to use it to upgrade the firmware?

It is under “Add built-in app”.

Yes, many times. I even moved the hub right next to the devices. One of the devices shows completed during the update but then when I review it still shows 1.31 firmware. This unit was the original pre-released special promo units. It is also the one that disconnects continuously in my bedroom. The other 1.31 unit did upgrade finally to 1.36 using the firmware updater. Neither would work using the Hubitat Z-Wave firmware updater driver which worked for your other non-fan/light devices.