Firmware v1.48 (Beta) | LZW31-SN | Dimmer - Red Series (Gen 2)

We are releasing a beta firmware for LZW31-SN users as a follow up to v1.47. It fixes the S2 bootstrap problem that is being seen on the Hubitat C-7 hub.

More information can be found in the link below.

This firmware should be stable, but if there are any issues, please let us know.

6 Likes

Thank you for putting this out! So dimmers on 1.47 firmware only needs the target0 to be updated? The bin doesn’t need to be patched?

2 Likes

Yep, that is correct.

3 Likes

Ah, was quietly hopeful that this included the configurable delays for double tap and for hold :slight_smile:! We’d keep waiting patiently!

2 Likes

Is there any reason to update if we are not on Hubitat?

For when you upgrade to Hubitat, it’ll already be done. :slight_smile:

6 Likes

The update here is mostly within the Z-Wave SDK, which was failing against S2 not only in Hubitat but in the SDK testing environment as well. Though I’m not aware of problems with other hubs, it’s reasonable to predict that other 700 chipset hubs could be impacted as they get to market. Today, Hubitat is the only game in town, but it won’t be that way for long.

1 Like

I think I am having an issue with this firmware on Hubitat 2.2.3.142. When the “Disable Remote Control” is set to “Yes”, the LED Color child device does not respond to commands from the hub (for example to dim the switch LED to the level of a smart bulb controlled by the switch).

Will there be an equivalent firmware update for the LZW30-SN or is the problem addressed by this update unique to the LZW31-SN? I’m currently running on a Hubitat C-5 hub, but have a C-7 that I’ll be moving to once their firmware stabilizes a bit more.

My LZW30-SN never had any difficulty with S2 security. At least that problem seems to be unique to the dimmer.

Do you want to try to update to the hotfix that was released today? Maybe a driver update would be needed from Inovelli side

I’m running it now, but even on 2.2.3.142 my LZW31-SN dimmers were happily joining with S2 and doing SmartStart. I’ve got 1.48 running on all 20 of my dimmers, and 5 of them on S2 so far.

I did have an impressive variety of other problems that I can’t describe well over the last 24 hours while applying patches and trying to get everything working. Problems at various points in time included devices being unresponsive to the hub, ghost devices appearing again (2 ghosts for the single same historically problematic LZW31-SN that had been joined with S2 even before the fix came out, one of which was not even visible at all from the PC Controller, not even as a failed node), needing to reboot for inclusions to work, needing to reboot to remove the ghosts, and then finally logs full of Z-Wave busy messages and total network non-responsiveness. But I changed so much so quickly when I was updating, testing, and getting everything on S2 that I’m not sure what’s to blame. I am just confident that as of 2.2.3.142 if you press your luck with enough exclude/include cycles you can still screw things up rather badly.

My present state is not too bad. Besides the unexpected failure to control the LED devices above I got things working again, albeit using rather primitive and brute force tactics of force removals and aggressive use of the secondary controller. And thanks to EricM’s LZW36 fix I can control the Fan/Light LEDs now, so I should soon approach my end state: everything on S2 with LEDs that reflect the state of their smart bulbs. Huzzah.

It would appear that you must update first to 1.47 as after updating to 1.48, the 1.47 bin cannot be applied to dimmer’s node 1. I am downgrading node 0 to 1.47 to see if this fixes it so that i can upgrade node 1 with the 1.47 bin

This wasn’t true for me using a Z-Wave stick to upgrade.

Anything is possible. I used a Z-Wave stick to upgrade too. I applied 1.48 twice, and could not apply the 1.47 bin… I then installed 1.47 orz, and the 1.47 bin installed in just seconds w/o a hitch, and I then applied the 1.48 orz again.

I first tried this 1.48 otz and 1.47 bin on my guest room dimmer by pairing it directly to my z-stick… it died after applying 1.47 bin to target 1. It won’t talk to the z-stick anymore, and it will power on, but won’t no local control, or led bar display after the power on light show.

I could not recover it, so I tried my office using the Z-Wave Firmware flashing driver for habitat, and it worked beutifully, but again the same results – I could only apply 1.47 bin if I applied 1.47 otz. Finally I flashed my meter bedroom, and too worked flawlessly using hubitat’s flasher tool. Frustrated I no longer had light or fan control in the guest room, I removed the dimmer, and put in a replacement (I have several spares I haven’t gotten around to installing). This one, being brand new, I did 100% over z-stick, and same thing. So, my conclusion is that the 1.47 bin, for what ever reason cannot be in stalled after the 1.48 upgrade (at least when the old firmware is much older anyways… all mine were 1.3x (not sure which).

I was able to work through the various problems I faced with ghost nodes and include/exclude issues.

I now have 20/20 LZW31-SN running 1.48 and connected to the Hubitat C7 (2.2.3.145) via S2, and responsive to hub commands. They were all added via SmartStart, which when it worked grabbed them reliably in under 2 minutes.

Was there any other bugs you found? I swore I read somewhere about one of the parameters being messed up or something, but honestly, I may have been dreaming :laughing:

This?

1 Like

Thanks, Mraz. I think that is my only open/unresolved issue (other than the LZW36 flicker).

From previous behavior, I do not expect “Disable Remote Control” to impact events on the LED Color child device.

2 Likes