Help With 3-Way

Thanks for sharing this, @akguwabr. @Eric_Inovelli @EricM_Inovelli I don’t see the configuration options mentioned above, in the SmartThings Device Handler. Is there any other way to configure these options with a ST hub, or an update to the Device Handler?

I had the same issue with the dumb switch not working. I had set the 13 to 1, but also had to set 12 to 1. The dumb switch setting worked but it looks like neutral default state is wrong. I had to set the neutral to 1 and then it starting working.

Lol – check your spam folder. Subject Line should be: G8 3-Way Issue oh and You Start Monday Congrats.

What you do in your own time is your own business – I’m out on that one!

1 Like

Yes, this is normal – you’ll also likely hear the relay in this setup too :slight_smile:

Yeah, great find – It’s really strange because when we tested the firmware that was approved, it worked as normal (hence when we wrote the Wiring Insert instructions) and then after people started posting about it in the forum (thank you btw) we realized that there is likely a mistake on how the firmware is setup (ie: by default it’s set as non-neutral). The weird part is that when we asked the manufacturer about it, they said that they set the default to neutral, so we’re still looking into this.

However, when we made the YouTube videos on configuration:

We noticed the same thing (I had to program the switch to be neutral).

Yeah, they should be in there (Dimmer switch – On/Off does not have this capability) – make sure you downloaded the right one located here: LZW31-SN Device Handler

Then, in the Classic App, click on the Inovelli switch and then the gear icon at the top right of the screen to take you into the switch menu.

Next, scroll down to where it says, “AC Power Type” and “Switch Type”.

  • AC Power Type = Neutral vs Non-Neutral
  • Switch Type = Single Pole, Toggle (Dumb Switch), Momentary (Aux Switch)

After beating myself up and setting up a little test jig I found this thread and changing the neutral setting worked for me as well. Thank you @Newlance! Seems like the switch wasn’t setup with neutral wire as the default so the instructions are missing that part. Now that it’s working I find that if I cycle the dumb switch quickly I sometimes have the smart switch missing a change. So if the dumb switch is toggled up for lights on and down for lights off, if I switch the lights on and then off quickly the smart switch will sometimes miss it and then when you switch the dumb switch again it’ll turn the lights on and then off quickly to “catchup”.

TLDR: If your switch isn’t working in 3 way and everything is wired right, go to #12 parameter and toggle up one time and then do #13 like it says. Still have a minor issue when quickly switching the dumb switch on and off though.

Sadly the non-dimmers do not have this feature and some of us appear to be stuck with the switch not working as intended.

I think we may be having the same issue. But I have faith that Inovelli will get it right.

I too want to believe they will get it right but it seems there are a lot of 3-way issues right now across the board and there as been little to no official responses on them.

For now, I’ve moved the three Red Series ON/OFF switches to basic 2-way setups. I will keep monitoring the forum for better support for 3-way on these switches. Fortunately, I only have three more 3-way locations to accommodate, so I can wait. I’ll replace my Leviton Wi-Fi dimmers in a few months once the firmwares debug and stabilize across the lineup.

Same issue here as well. I’m afraid I might have burned up one of my new switches while trying alternate wiring configurations :frowning:

I did set the 3-way mode via the switch using the instructions on the insert, but didn’t help. It only started working properly after I set the mode through the smartthings app.

I wanted to add my experience before finding this thread with the neutral-default bug in case it helps anyone else.

Setup 1: 3-way

  • 1 Inovelli Dimmer
  • 1 HomeSeer Aux Switch
  • Neutral going to both

If I turn the light on via the dimmer, I can shut it off with the Aux about 90% of the tries. If the light is off, and I try to turn it on, it would work about 20% of the time.

Setup 2: 4-way

  • 1 Inovelli Dimmer
  • 2 HomeSeer Aux Switch
  • Neutral going to all 3

If I turn the light on via the dimmer, I can shut it off with the Aux about 90% of the tries. If the light is off, and I try to turn it on, it would work about 10% of the time from either Aux switch.

In all scenarios I am measuring around 40-50 V between the Traveler and Neutral on the Aux switches.

With this fix of updating Setting 21 (12 taps) to reflect Neutral, the above problems have been resolved.

Did you mean setting 21 (not 12)?

Good catch, I just fixed my post.

I’m still having problems with my LZW31-SN dimmer. I have it in a setup with a manual on/off toggle switch on the other end. The Inovelli dimmer has been updated to netural and 3 way/dumb with both the youtube instructions and through Smarthings by selecting AC Power Type Neutral and Switch Tyler - 3 way toggle.

I’ve already burned through one switch and concerned I may burn through a second if I keep trying different combinations.

With the wiring I have line in one box and load in the other. When I control from the Inovelli the lights go on and off as intended When I control from the dumb switch, the lights don’t turn on. The dumb switch will however turn off the lights if they are already on.

Any idea on how to get the dumb switch to control on and off functionality properly? Is it my wiring, the setting or a switch that I should be looking at?

@EricM_Inovelli It seems to me there’s a significant data point that has been brought up in this thread that needs highlighting because that may lead to a solution at your end. A number of people in a 3-way configuration have reported that things started working after they set parameter 21 (AC Power Type) to Neutral. Neutral is the default. We should not have to set it to Neutral, yet here we are. My own experience also confirms it. At first I switched parameter 22 to 3-way Toggle and left parameter 21 alone because the default was right. (I’m referring to the parameters number for the LZW31-SN.) Then I went to parameter 21 and explicitly set it to Neutral through Home Assistant. Note that Home Assistant was already reporting that it was Neutral, but I ignored that and asked HA to set it. It sent the ZWave command, and after that this problem was gone. (I ran into another one… but that’s another story.) Then I came here and found some people essentially describing that they did what I did: even though Neutral is the default, they set the parameter to Neutral.

For me this looks like a bug in the firmware of the LZW31-SN, where it reports values that are the defaults expected, but in fact it is operating with values that are not the default. Maybe these are the values used in testing? There’s a note in the installation instructions mentioning that it is possible during the testing process that a switch won’t be excluded from the testing network and may get to the customer still included in the testing network. Maybe there’s sometimes a similar problem with testing parameters? The switch still operates with parameters used in testing, though it reports the expected defaults?

1 Like

Correct, went through and changed all 30 dimmers to a hard default of neutral . There is one other thing I noticed that a lot of people have been complaining about. They say when they flip on their switch the light turns on gets up to full brightness and then shuts off. I have found when this happens to set the parameters for brightness at 90% . The switches stay on and all is good. I have no way to officially test this however when I use the smart switch I think my light is about 10% brighter than on a dumb switch. Again, I really have no way to test this except for visual but I would bet money on it . :).

I think you are correct on this. I’ve been banging my head on trying to find out why the default is set to 1, but people are still having to set the parameter.

The conclusion has to be that upon initial inclusion, the device is reporting a value of 1, but is performing like it has a value of 0 set. This is something that we will run by our engineering team.

I’m having the “smart switch turns off when dumb switch is turned off” problem too, but I checked the IDE and my paramaters are set correctly. So, the problem is bigger than just a default setting issue.

1 Like

Hi @shahar, can you let us know what your wiring looks like?

@EricM_Inovelli I’m having the same problem as @shahar.

I’m using Hubitat, so it was easy to confirm that I’m running in AC=neutral and type=3 way toggle, and still having the issue with my RED Dimmer. If the dumb switch is off, the dimmer doesn’t do anything. When I try to send it a command or turn it on at the switch, I hear a click, but nothing happens.

I tried reversing the line and load and still had the same issue. This was the same issue I had when I tried putting the dimmer on the other switch of the 3 way with the same results.