Maximum mininum level of 45

One of my favorite options of the dimmer switches is being able to set the Minimum Level in the SmartThings device options. However, the maximum minimum level is 45. Is there any reason it can’t be higher? I have a ceiling light that still once in a while turns off at 45% brightness. I think setting it even to 50% minimum would work for me.

@EricM_Inovelli

The main reason was to avoid the programming conflict if someone set the minimum level greater than the maximum. For example If the user sets the minimum to 60 and the maximum to 40. We also didn’t believe that there would be a use case for a minimum over 45. Of course there are always outliers like yourself. :wink:

I could see about upping the minimum to 50 . . .

thanks! that would help me out a lot!

I’m thinking it would be useful to be able to set the minimum to 100% (or maybe 99) to make it act like an on/off switch rather than a dimmer. One case would be an installation that has non-dimmable fluorescent lights but will be upgraded later to LED. An alternative be another confing parameter to make it act like on/off only but I think allowing the minimum dimming value to be 99-100 would be a simple way to effectively disable dimming when needed

1 Like

I’d be another user who wishes I had more control over minimum dim level. Some of my fixtures don’t properly light till 50-55% and I’m trying to avoid the use case where people hold the paddle down and think it’s off when it’s just dimmed below the necessary threshold.
If you’re worried about conflicts between min/max dimming, a simple logic check before using (or setting) the value would solve that: IF max_dim <= min_dim THEN max_dim = 99.
Slap a line in the documentation that max dim value is ignored if set at or below the minimum dim and call it a day.

2 Likes

Definitely interested in a higher minimum also!

1 Like

Using the LZW31-SN Red Series dimmers with the v1.57 firmware, I am able to set the minimum dim level as high as 98% using Home Assistant via the ZWaveJS2MQTT configuration panel. It seems to work as expected! I tried this on the v1.47 firmware and it was not possible.

If using Home Assistant, you need to use the ZWaveJS2MQTT panel to set the configuration, not the built-in Home Assistant Z-Wave configuration panel. The built-in panel restricts the set of valid values (correctly based on the device’s Z-Wave config). The ZWaveJS2MQTT panel seems to skip this validation check, letting you try to input any value – and it works.

Here’s a screenshot of one light with the minimum set to 46%, vs the prior max minimum of 45%.

1 Like

I use Hubitat and many months ago, I changed the device driver in Hubitat to skip the validation check and allow values higher than 45. But what I saw was even though it allowed me to ‘set’ higher values it didn’t actually change the behaviour in the dimmer. When I asked @EricM_Inovelli about it, the answer was that the firmware inside the dimmer still restricts it to 45.

Interesting! Well, all I can say is I tried it again and it still seems to work on v1.57. Here’s the behavior as an example:

  1. First, set the maximum brightness to 85%.
  2. Set the minimum to 85% (min = max): light doesn’t get any brighter or dimmer when I hold the switch up or down.
  3. Set the minimum to 46% (min < max): light dims again, and stays on at the minimum value.
  4. Set the minimum to 45%: light dims, but turns off at the minimum value (not enough power for my particular light).
  5. Set the minimum to 90% (min > max): the setting does not take effect because the minimum it greater than the max (85%). It changes back to whatever it was set to previously.
2 Likes

Wow, that is crazy, it looks like the firmware engineer may have slipped it in. I tested and I am able to set the minimum past 45. I stopped at 98, which it did accept.

So, does it seem that the higher setting actually does change the minimum? It isn’t just changing the setting without having an impact on performance right?

1 Like

For me it changes the minimum for real. I am very happy to be able to set my mins to 46% instead of 45% :slight_smile: !

Maybe someone else with Home Assistant & ZWJS2MQTT and v1.57 firmware can give my steps above a try to confirm?

1 Like