Need help with NZW97 Two channel outdoor plug

Today I replaced my Wink with a ST hub. I am unable to connect my NZW97 plug to ST.

I understand that the NZW97 is discontinued by Inovelli, and since I don’t see this device listed as an option in the ST app I understand that this means I need to add a device handler.

I learned how to get to the IDE, and I found the code here on this site that apparently can be used to create a device handler for this plug. I created and published the device handler, and it shows up in my app. But it doesn’t actually work. And what I see in the app is just one device. I would expect to see three, like I did in Wink. One for the device itself and one for each of the two plugs.

Perhaps I need to “exclude” the plug first? It’s deleted from my Wink, but is there a way to exclude the plug from the device? Push the button 5 times, or something like that?

I feel like I’m missing a step with the device handler. There has to be some physical step to pair the actual device, but I’m not seeing how to do that.

Help? I hate to get rid of this plug. It wasn’t cheap, and worked very will in Wink until Wink fell apart.

Thanks in advance

Go here for the manual. It has ST install instructions.

Checkout I installed inovelli-2-channel-outdoor-smart-plug-nzw97.groovy then found I needed switch-child-device.groovy to get switch 1 & 2 to show up. You’ll needed to disconnect and reconnect the switch after installing the device handlers.

Thank you @eswebber Perfect!!!

Hi, I am in the same boat As @fritz was regarding the NZW97. I am able to install, I see one device then add handlers and the parent and child devices show as on but not operational and the parent does not work at all, Any help would be great,

So I currently have 2 of these devices. They are paired properly but they seem to only work as long as they a wall apart from each other.

For example i have one out by my back porch and this will only work if the other one is plugged into the wall on the inside of the house. (I know your thinking its the zwave network isn’t astong enough) however i also have a zwave deadbolt on that door as well as a zwave switch within 12 feet of the plug.

I’m just baffled by this. And have been for a bit

Maybe do a Zwave repair? Perhaps that device is “stuck” looking for the other.

Following up. Look in the ST IDE for the device you are having problems with. Find the device in “My Devices” and open the “Show Device” page. Look at the Route. If you see the other plug in the Route, then remove the other plug from power and do a Zwave network repair.

What may be happening is that the problem plug is routing through the one you moved, and after you moved it, the problem plug can’t reach the other one. If you Zwave repair, this will establish a new route to the hub NOT going through the other plug.

Sorry for the delay in getting back to you. I’m gonna have to try this. Will follow up with results

So i tried that. And it switched. However i plugged in the other plug again and did another repair and it went right back tobusing the other plug. No idea why it keeps doimg that. The plugs are about 50 feet apart. Maybe i’ll try to remove them and add them again tomorrow

There is nothing wrong with the one plug using the other to hop. I was thinking that it wasn’t working because it couldn’t reach the other plug after it was moved. But it obviously is if it gets connected via a zwave repair. Do they both work now?

Hello all. I was updating my device by adding in a new Device Handler, as the new Smartthings app didn’t really see both virtual switches in my Inovelli NZW97 outdoor (dual) plug. It would only turn on one switch / outlet (after moving from classic app to new). So I created a new Device Handler and then changed the type in my device.

Now the new Smartthings app says it “Can’t connect to device. Check device and try again.” To be safe, I unplugged and re-plugged the NZW97 back in. I have removed and re-installed the Smartthings app. Same error.

I am able to use the Smartthings Classic app. It is clear the device type / handler was updated, and it works like a charm. I thought to manually test from within the Alexa app on my phone and it too worked like a charm. But the new app just looks at me and laughs. Any thoughts on what else to try here? I could try to remove the device from my app, but it looks like it wants to fully exclude it and then I assume remove from my hub as well. But if I do that, and re-add, I believe it adds it back in as the old, default device time of a generic z-wave multiswitch; of which I’d have to re-setup again.

If it matters, I have also installed this child switch device handler.

Thanks in advance for any ideas or thoughts on this!

SmartThings is kind of in an interesting state right now as they are between multiple “old” integrations & “new” ones. Because of this things are changing frequently. They have a device handler that mostly works with the new app named “Inovelli 2-Channel Smart Plug MCD”. It is already integrated into their system. I don’t think the endpoints work with Alexa or Google Home though. Also, last time I checked, it didn’t allow you to use the endpoints in their “Automations” setup. Maybe that has changed but I haven’t checked recently. This was supposed to be the way they were going forward with multi-channel devices and it is a device handler that they worked on.

I think the best option that is working today is a modification that I just made to the device handler in our github. You have to delete the child devices that are currently there and recreate them by saving the preferences (after you update the handler) for the device or re-include the device, but the new child devices should work as expected (at least as of right now).

1 Like

Why did Inovelli discontinue this product? I have been looking for an outdoor smartplug with multiple plugs.

I wish we didn’t – we really loved this product. Unfortunately, we had a falling out with our old manufacturer who has the rights to this design, so we can no longer sell it.

Maybe one day we’ll create a new version!


At some point you really just need to start a Kickstarter for these projects, so we can help accelerate the funding :wink:


This is a great idea! I’ve wanted to do the outdoor plug for awhile now. Think it would be a huge seller!

Thanks, @EricM_Inovelli. I updated my device handler and switch out the child, per @Eric_Inovelli recommendations. That didn’t seem to fix my issues with the newer Smartthings app. However, I followed the guidance here, by excluding and removing the device and then adding it back, and the new app found the NZW97 and appears to have used (kept) all of the new device handlers I added.

I’m back in business! Thanks.

1 Like

I have been migrated to the new SmartThings app and it appears to have broken my child connections on my NZW37. Is there a way to put the child outlets on the main list of devices screen, instead of hiding them in the parent outlet view?

I have NZW37, and have re-paired it to SmarthThing hub and recreated the child devices to show as devices in the all devices list. This seems to work. however the parent shows 4 devices (but only 2 show in the all list). the two that show in the all devices list from the new smartthings app continually say Checking Status. is there anything to resolve this?