Red Gen On|Off Switch (LZW30-SN) and Association to Ilumin Bulbs

I have an Inovelli Red On|Off Switch (LZW30-SN) and three (3) Inovelli-powered Z-Wave Ilumin bulbs. I’m trying to get the Z-Wave Association to work. I am looking for the light switch to immediately (via z-wave association) to turn the lights on|off. Sounds simple, ya? Using new SmartThings App, Gen 3 hub. Latest firmware all around. I got the Ilumin bulbs as I “assumed” it would be easier that way… but alas…

  1. Adding the switch to the SmartThings controller was successful using the QR Code it came with (ie the S2 Z-Wave security level)- recommended by Inovelli. (More on this later…)
  2. Adding the Ilumin Bulbs to the SmartThings Controller- done. Of course the bulbs didn’t come with a fancy unique QR Code for each one so these are added with the S0 LEGACY security level. (More on this later…)
  3. I have updated the devices through the groovy interface to have them use the Inovelli device handlers successfully (raw, copy the code).
  4. I have installed the Association Tool & the Association Smart Apps, and followed the directions to create the associations. In reviewing through the groovy interface, I can see each bulb being part of the association group and the switch having Group Two with the three bulbs in it. Lookin’ strong.
  5. I have disabled local control at the switch so the Smart bulbs are always powered.
  6. However, pressing UP/DN on the switch has no effect. I was under the (misguided?) impression that once the association was established, the hub was out of the picture.

After scouring the (this) Community, some suggest that you cannot create an Association between a z-wave controller/switch and associated devices that use a differing security level…

My question: Is this true? And, if it IS true, then how do I “avoid” the QR Code setup step when including (in the new ST app)?? Each time I try and escape out of this prompt, it includes the device but I get a security string of S2_FAILED-- And for the life of me I cannot get it to set to S0_LEGACY or something equivalent to the bulbs.

Oh ya-- and the association still doesn’t work.

So here are my questions:

  1. Once and for all: Must the switch & bulbs be at the same security level for Association to work successfully? If so, please explain how to set the security level of the Red Switch to S0_LEGACY, like the Ilumin Light Bulbs??
  2. Alternatively, What steps might I be missing?!?


I’m not too helpful with ST, but I thought I read the classic app is how people were getting to join network devices without security. Not sure if new app does.

ah, ok- well that’s something I could try… Thanks!

All device need to be on S0 security. Your switch is likely setup as S2. Unpair the switch and reinstall it without using the bar code. Instead, and if you use the new app, click add device than on the bottom of the page select scan nearby. Once light and switch are on the same security level, your association should work. You can use the classic app as well. Good luck.

1 Like

Awesome suggestion-- I will try this today! Thanks!

Thanks Loic, your suggestion worked like a charm! The switch is now connected as S0_LEGACY-- just like the bulbs. Now to re-do the associations! Thanks again!!

Glad to know it works. I went through the same challenges few weeks ago as well. When you’re done with your association, I’m curious to see what functionalities are present. I’d predicate if you can comment on this post I just started:

@anon14959390 trying to share the few things I know and learned from you :slight_smile:

1 Like

Awesome to see! I learned from @EricM_Inovelli and @Eric_Inovelli so I can’t take the credit!

OK. Update on the situation: I can only control 1 out of the 3 Z-Wave Inovelli bulbs. I have run (and uninstalled- which blows away the associations) the Association Tool, and it appears although I specify 3 bulb ids in Association Group #2, only the FIRST OF THE LIST (the one you check mark FIRST in the Association Tool) ever responds to the switch as expected (by turning on or off).

I have also tried changing parameter #5 (Association Behavior)… Local (01) works… but I’m back at the default (15) now. No change.

Any guesses as to what I’ve done wrong? Has anyone run into the “only one light controlled from Association Group” problem??

Aha! Searching (reading ALL the way down the page…) I found @EricM_Inovelli post that “this is a known firmware issue”. So, Now to install the (beta) f/w fix. (Firmware v1.16 (Beta) | LZW30-SN | Switch - Red Series (Gen 2))

Remember how I started out thinking this was gonna be easy?!

Always famous last words.

So, my firmware version is “1.09” according to the Groovy interface… Considering the Beta is at v1.17 should it not have pushed an OTA update already to fix this problem? My ST hub is set to Allow that.

Which raises the question, "Does Inovelli have an update schedule? Should I buy a $32 usb stick to update the firmware or just wait??!!!??


Unfortunately ST does not support OTA for z-wave devices (only Zigbee). Firmware updates have to be performed externally, typically with a computer and Zwave USB stick…

AFAIK, ST does not yet perform Zwave OTA updates.

Thanks folks-- a USB z-wave stick it’s gonna have to be! And the story continues…!

1 Like

Ah ah that’s part of the fun!

Step One completed: Z-Wave.Me USB stick has arrived from Amazon. Next is downloading software to flash OTA… (At least I’m not going into this part thinking “Well, this otta be easy.”)

Now to find the quiet, meditative, calm state of mind…

1 Like