SmartThings Device Firmware Update - Secondary Controller Method

@dsbaha, the source of the problem seems to be that the zwave stick is not connected in S2 Mode. In another thread they suggested to remove the the controller and repair the network then add it back. Update firmware on LZW30-SN

I have been working on it over the weekend but can’t get my controller to connect in s2, whenever I click Classic Learn mode, the device gets added automatically without security.

@dsbaha & @JasonMacD are you following the exact instructions in the KB article? If you do the inclusion in the old app or if you use the “Scan nearby” option it won’t use S2 inclusion. You have to go through the steps of choosing “Add device” -> “By device type” -> “Generic Z-Wave Device”.

I have been using the exact steps in the article. “Add device” -> “By device type” -> “Generic Z-Wave Device”.

I will have to attempt to go through all the steps again later tonight.

@EricM_Inovelli: I was able to get it to work after a few attempts tonight. I was following the instructions however I think that I was being quick on the steps. I had PC controller open on my desktop and on my phone would click start and immediately following would click classic learn mode.

When I slowed down and waited a minute for my phone to start inclusion mode before click learn mode it connected properly.

All of my switches are connected in S0 except for three. I suspect that the 3 were added in the classic app ages ago and need to be excluded / included first.

Thanks for the help,

1 Like

I am having the same problem, how did you exclude the PC controller?

If I remember I was having a few issues removing the controller. I found a few steps online and had to put my smartthings in exclusion mode. Once in exclusion mode I went to the PC Controller in the mobile app, click the 3 dots and “edit” and in the settings
select delete device.

I believe the removal timed out and I could select force delete.

Did your PC controller appear as a Switch in SmartThings? Mine didn’t give me the DSK option and appeared as a new light switch.

No, it always looked like a controller. My problem was that it was not connecting securely.

You can put SmartThings into exclusion mode and then initiate “Classic Learn Mode” in PC Controller to exclude it.

1 Like

I’m still struggling to get it connected, in learn mode, it just doesn’t register.

Did you have the same struggles?

I keep getting a “Replication Error Failured” message in PC software.

To be honest, I don’t really remember. Once I figured out how to remove and got the device linked in secure mode it was smooth sailing.

I think that I did find is that distance had a huge impact on the stability. The further I was away from the hub and the more devices it had to associate with things slowed down and I had more errors. What I ended up doing is installing PC Controller on my laptop and moving around the house with the hub and my laptop keeping everything very close together.

My advice would be to start from scratch. Remove the device and PC Controller. Install a clean copy and get everything within a few feet of each other to set everything up.


How crucial is the Holtek bin file when updating the red series dimmers? I have been trying for 3 days straight on my 7 dimmers and have only managed to get the bin file to stick for 2 of them. The update seems to just freeze at random - resulting in me having to abort and restart the process - with not much luck - especially frustrating when I reach 300+ packets sent out of 396 and then it stalls…

Is the bin file’s sole purpose to allow setting LED bar to white? If so, I can live without that.

I’m on Smarthings and using a Zooz S2 stick with Silicon Lab’s new “Simplicity Studio” that has PC Controller Ver 5.42.101 loaded.


I don’t know if anyone has tried 5.42, but it’s been recommended that only 5.39 PC Controller be used. I would recommend trying 5.39 and see if that works.

The holtek file is required for some of the firmware fixes and should be updated to the latest available file that matches the firmware you’re flashing.

Interesting - is there a way to downgrade PC controller versions somehow? Or do you have a link to the “legacy” version? Silicon Labs now makes you download Studio first (all old links on Inovelli site to PC Controller no longer work, to my knowledge) and from within that tool you have to download PC Controller…and the 5.42 is what they provide by default.


Check out the link here:

Sweeet - I’ll give this a shot and see if the version is the culprit. Appreciate it.

Well - it was worth a shot - tried twice and the last time it got stuck on the 140th (or so) packet and I got the log says: unable to receive = 0x01.

I may have to try the direct method to see if that works better.
Thanks again.

1 Like

@sparq - Make sure 5.39 actually was running too. But if still no go, could you update your results to let everyone know that 5.42 worked to upgrade?

Definitely worth trying to exclude and try to do it direct.


I can confirm that 5.42 works to update the main switch firmware (as I can see firmware version 1.48 within PC controller on the “get” command) - and 5.42 also worked to update the bin file after repeated tries for 2 of my 7 switches. I will try the direct method on one of the switches and report back if I have success.

I believe PC Controller pre 5.39 had issues with Target 1 as well and that’s why it was recommended to use 5.39. I hope whatever fixes in 5.39 were, it was incorporated in 5.42…but you never know.