"Start Level Change" changes lights abruptly

Hey, all. I have a few different products (two black-series dimmers and an RGBW bulb) that are all experiencing the same behavior: If I go into the Hubitat device page and click the “Start Level Change” command, the level changes to 0 or 100 basically instantly. Even if I set the dimming speed to something higher, it doesn’t matter. And in fact, on the black-series dimmers, if I set the ramp rate higher than 1 or 2, pressing “on” is a slower way of turning on the light than pressing “start level change”.

This matters because I’m trying to use Hubitat’s Mirror app and a remote by RGBGenie to control dimming of these lights from somewhere other than the Inovelli switch. I believe the command the remote is sending is the same as the “Start Level Change” command that I’m using from the device page. So the remote isn’t dimming anything.

Help? Thanks!

Just commenting to bump this for myself to test when I get home. I’ve never actually used the Start Level Change, so I’m curious!

Hopefully someone more familiar with Hubitat can jump in – but I’ll give it a shot in the meantime.

Give me a couple hours :slight_smile:

Edit: Ok, so I don’t have a Black Series to test, but I think I’m seeing the same thing you are on the Red and Blue Series.

Here were my settings:

  • Dim Speed = ~10 sec
  • Ramp Rate = ~Sync to Dim Speed

If I turn on and off the light remotely, the dim and ramp speed works as intended. However, if I turn off the bulb and then press, “Start Level” (Up), it comes on instantly.

Logs seem to reflect the 10s setting:

Admittedly, I’m not sure what Start Level does as I’ve never used it, but it seems to ignore the settings of the dim speed and ramp rate.

Is this what you’re seeing?

Yep, that’s exactly what I’m seeing. Just tested it again on a red dimmer (though one with older firmware, 1.35/1.34), and it’s the same behavior. I’m not sure what is supposed to happen with “start level change”, but what I would have expected is that it would start dimming up or down, at the dim speed, and continue doing so until either it reached 100/0, or until “Stop level change” is called. This is…not that. And it doesn’t feel intentional because of how it ignores dim speed and ramp rate. Feels like a bug.

Thanks for verifying!

My understanding of the start/stop level change is that the bulb must support transition time (which it does), but the driver must also have a start/stop level transition setting. The start/stop level change doesn’t use the regular transition time setting.

It look to be a driver problem. I got this bug with LZW42 with hubitat driver and with inovelli driver but if I use the Generic Dimmer driver the command work as expected.
I use this command when I want dim up or down the bulb when I held a button and execute a Stop Level Change on release of this button.
I address the problem here

And here

Just curious, does the light report the correct value for the “level” attribute under “Current States” on the device page? If not, does a “Refresh” help, and if so, does the “Start Level Change” command work correctly after that? (You shouldn’t have to do this, just trying to narrow down a possible problem if this is it…)

Just tagging @EricM_Inovelli for visibility.

Yes, the level is correctly reported throughout. I did this test with a black-series dimmer:

I tried setting the level to 45 (it reflected in the attribute correctly). I refreshed (nothing happened). I started a level change up (the level attribute changed to 99 immediately, and the light’s brightness did as well). I repeated that procedure except started a level change down (the level attribute changed to 1 immediately, and the light appeared to turn off, though I did not hear the relay click, and the “switch” attribute remained “on”).

From my understanding of the start level change is that the bulb must support transition time, and the driver must also have a start/stop level transition setting. Without the setting in the driver, it completely ignores the regular transition time and will just instantly jump to the set level.

1 Like

level change down to 1 is still “on”. That is normal. Depending on your actual bulb, it may be too low a voltage to light up, but as far as the switch is concerned its still ‘on’

Hmmm, I will check it out. I’m not sure if I have used that feature on our switches.

2 Likes

You were testing with a Blue series switch. The Blue series StartLevelChange function is [mostly] working properly (with a slight caveat noted below). The OP’s issue is specific to the Red series

This particular scenario with the Blue series is related to a new bug introduced in the Blue series v10 firmware. Its noted in github issue #89 It is unrelated to the issue with Red series

Is there some news about driver code patch?

No news yet, but I promise it is on @EricM_Inovelli’s list of things to look at. We are currently wrapping up the 2-1 firmware and after that we should have some time to take a look. Unfortunately one of the setbacks of only having one guy who can write firmware – very low bandwidth. However, it being what looks like a driver issue, we will certainly want to get it fixed not just for the bulbs, but for switches as well.

It looks like @bcopeland was also looking into it in the Hubitat thread: Inovelli bulb multicolor driver bug - #3 by bcopeland - Built-in Drivers - Hubitat

Sorry for the delay – keep bumping this, I promise we don’t mind.

1 Like

The tread on hubitat community is mine but bcopland don’t gave news about his tests.

Thanks for the follow up. :+1:t2:

1 Like

@joshr @marcmale I have updated the drivers to fix the start level change problem. Please let me know if you see any issues with it.

6 Likes

Nice, thanks! I’m away for a few days but I’ll check when I get home.

For my own edification: Comparing e2db7172...d881c8c5 · InovelliUSA/Hubitat · GitHub

With the old driver my lzw42 instantly go off or 100% bright. Now with the new driver nothing happen when I press “start level change up or down” I set the dimming speed to 3 sec.

Just fyi Its working for me on LZW31-SN Red Dimmer. Not sure what’s different with lzw42 since the github change looks the same.

1 Like

@EricM_Inovelli I also confirm that it working on LZW31-SN but not on my LZW42.