VZM35-SN Zigbee Blue Series ZHA - Fan Template For Home Assistant

Here is a fan template that seems to work pretty good with HA. There might be a way to improve it so let me know if there are any tweaks. You just need the entity id of your fan to use. Anywhere that you see “light.inovelli_vzm35_sn_light” you need to put in your id.

  - platform: template
        friendly_name: "Bedroom fan"
        value_template: "{{is_state('light.inovelli_vzm35_sn_light', 'on')}}"
        percentage_template: "{{ (state_attr('light.inovelli_vzm35_sn_light', 'brightness') | float(0) * 0.392)  | round(0)}}"
          service: light.turn_on
              - light.inovelli_vzm35_sn_light
          service: light.turn_off
              - light.inovelli_vzm35_sn_light
          service: light.turn_on
            brightness_pct: "{{ percentage }}"
              - light.inovelli_vzm35_sn_light
        speed_count: 3


Edit: I just noticed that @MasterDevwi had already done this. Could have saved me a little time if I had remembered:

ZigBee Fan Switch | Project Zephyr (Blue Series) - So Hot Right Now / Projects & Roadmaps - Inovelli Community


One thing I noticed is that when controlling the fan at the switch, sometimes the level isn’t being reported correctly in HA. Showing that it is on vs off always works. I think there are some preset percentages for low, medium, high that when controlling from the switch it doesn’t reach. This is one of the areas that can probably be improved. I saw this somewhere in the HA forums that I think can be put inside of “set_percentage”, but I didn’t have time to figure it out.

brightness: >
              {% set mapper = {0: 0, 22: 56, 42: 107, 75: 191} %}
              {{ mapper[percentage] }}

Can you provide a bit more explicit guidance on how to use this template? More specifically, where the code is supposed to be saved?

Are there any plans on making this process a bit less painless? I have a bunch of these installed and it’s a pain in the butt to have to do this for each one as a workaround.

Thanks !!! But I returned the switches and will stick to what I have right now (Zwave).

Does anyone have this working with home assistant / ZHA? I bought two of these and can’t get either to work. The installation instructions are out of date, and although I’ve done my best to set all the entities to the right settings, I still can’t get either to work. (yes, it appears to be a fan switch, but only the light switch is exposed.)

When i turn the “light” on and off, (keep in mind, neither fan HAS a light) the fans beep. That’s it. Someone, anyone, help?

Hi @Chris_SEA, can you let us know some additional info on the fan you are connecting? If it beeps when you power on the switch it makes me thing there is some kind of remote control module inside of it. I might be wrong though, but I for sure want to get it figured out.

By the way, there is a firmware update that adds an extra entity that appears as a fan, but the light entity is capable of controlling it by changing the level up or down. The different speeds are defined here:

1-33 (1-85) Low

34-66 (86-169) Medium

67-99 (170-254) High

On the left is the percentage value and on the right is the Zigbee level value.

Lastly, I do want to mention that for safety reasons the switch is by default in On/Off mode so there is probably some configuration that we need to do to get things up and running (if it is a ceiling fan).

Hi Eric, thanks for your response, but I need a little more help here…

A few questions:

  1. I just updated the fan switches to beta firmware 1.07
  2. Is there a way to expose it to Home Assistant so it sees it as a fan and not a dimmer or switch?
  3. I can disconnect the remote control modules in the fans, (ideally I’d like to be able to continue using the remotes as well, but if not that’s ok), if I removed, how would I wire the fans to the switches exactly? There are 4 wires in each. Do you have a wiring diagram i can use?
  4. They are both DC fans… Does that make a difference? I’m getting the links to them from my wife…

This switch is rated for AC fans only. DC fans aren’t supported.


If you re-add the switch with firmware 1.07 it will add a fan entity. If you don’t want the dimmer endpoint any longer you can disable it.

I need more info on the fans. If there is an AC transformer that is powering the DC fan then that might work. The remote would probably work in on/off mode but that might not be preferred. If you get me the name and model I can get a better idea.

Sorry that took me forever. Here are the two models I’m trying to control:
FAN #1
Amazon.com: BOOSANT 60" Ceiling Fan | Manual

FAN #2
VONLUCE 52" Industrial Ceiling Fan

Any chance we can wire the blue fan switches to the control modules?

You can wire it to the fan switches and run the switches in smart fan mode.

No you won’t be able to use the switches as the 3 speed/multi speed mode because each of your fans are DC motors and the switches only support AC motors in multi speed mode.

I should have done my homework before I bought those fans! Live and learn…

Question to all: Is there a way I can repurpose my blue fan switches as regular light dimmer switches by flashing the firmware or changing some of the Zigbee attributes in ZHA? I’d rather not return these two fan switches, and I have no other use for them. I wired it up to some ceiling lights and although the switch works, the dimmer is not working correctly.

I was just racking my brain and could only think of using it as an on/off switch for your current fans. Or you could put them in your bathroom to control the bathroom fan. Do you know the model of bathroom fan you have? I looked for the instruction manual for the fans you posted, but couldn’t find them. Some fans will have an RF receiver inside of them that can be swapped out for our VZM36 (which can then be controlled with the VZM35-SN). I don’t think your fans are like that, but I was trying to check to make sure.