Blue 2-1 - Z2M, Groups, Binding, and Multi-Press Actions Troubleshooting

I’m attempting to troubleshoot issues with multi-press actions of the Blue 2-1 switch using Zigbee2MQTT (with Home Assistant). I believe I’ve narrowed down the issue a bit, but could use some feedback.

I’m running the most recent Z2M (1.28.1), and the switch successfully joins my network. I added the switch to a group and have bound it to control some other lights in the group, and that works well. However, I could not get multi-press actions to register in HA or in the Z2M logs.

To narrow down the issue, I eventually unbound the switch and removed it from the light group. When the switch is not included in a group, I can watch the Z2M logs and see all of the multi-press actions reliably, and the events can be used for automations etc in HA. Including the switch in a group (even without binding it) immediately interferes: I cannot see any multi-press actions (or even the single up/down actions, though these do properly control the lights) in the Z2M logs and they do not register as events in HA.

Is there something I should look into to resolve this? Or is this possibly an inherent limitation of Z2M groups?

Unless you’re doing something fancy, I don’t think you need the switch to be part of the group. Put the lights in a group, then bind the switch to the group. Does that give you the functionality you need?

I had originally included the switch in the light group because the video instructions here included the switch within the group for Smart Switch with Smart Bulbs setup.

However, I had the thought to remove the switch and try binding it that way as you suggested, but the lights did not seem to respond to commands.

For additional info, the lights included in the group are the Juno wafer downlights discussed in this thread, which may not fully support binding like some other bulbs might. So they may be a source of my issues, if so.

I’ll test binding my switch to some of my Hue bulbs in a bit and see if the issue remains.

I’ll have to get home to check, but I’m pretty sure you need the switch in the group for it to work properly…

I was having a similar issue. Updated to the newest Z2M (1.28.1) a few days ago and disabled relay click and that seemed to get it working, also make sure you have button delay to something other than 0. Still in the middle of testing it and verifying that it works correctly though.

I also have the switch as part of light group and had that working, but after playing with the bindings to solve the same issue I couldn’t get it to work so I binded the individual lights to the switch.

After a tad more testing, I believe this is the case. Tested with some Hue bulbs and they would not respond to commands if the switch was bound to a group that contained the bulbs but not the switch, and did respond when the switch was included.

Unfortunately, when included in a group with the Hue bulbs, multi-press actions still did not seem to work.

What bindings do you have set up? The below works for me to have multi-tap actions in the same sort of setup:

2 Likes

At present, just LevelCtrl with the lights group (which is what’s show in the setup video):

However, I’ve tried adding OnOff as well. That seemed to generate some error notifications with the Juno lights, but otherwise didn’t seem to change function.

Edit: I’ll try this setup with my Hue bulbs and see how that goes.

Edit 2: It seemed to work briefly. For a few minutes, actions seemed to come through. However, after that they didn’t seem to register. I’ve had that happen before, but haven’t been able to isolate it.

It may be worth noting that the switches seem to create a lot of traffic on the network (image related) compared to other devices. Not sure if possibly that’s an issue or not.

It seemed some of this traffic was electrical power/energy related. I’ve adjusted some of the power and energy report settings, which seemed to help some, but also needed to increase the Min rep interval for some of the items under the Reporting tab to help reduce this, but there’s still quite a lot.

Edit 3: May also be worth noting that I use Adaptive Lighting, which includes some long brightness/color transitions for lights every few minutes. The lights groups that the switch is included in is controlled by this. Could the long transition times possibly be interfering? Tried disabling it for these lights, but didn’t seem to immediately make a difference.

Edit 4: One other observation - when bound/grouped, even the up_single and down_single actions don’t come through (even though the bound lights do turn on/off and dim properly).

I have noticed an issue where the tap events stop registering if the switch hasn’t been interacted with in ~90 seconds. Not sure if something is going to sleep inside the switch or it’s some sort of signal issue or what. This thread seems like a similar issue to this one: Blue 2-1 "Wake" needed? - #29 by harjms

Could you provide the IEEE (first 6 digits) address of the device?

Assuming you’re asking me, 94:DE:B8.

Other than the tap actions in a Z2M group/binding, it’s been working great using the most recent Z2M version.

1 Like

You’re switch is part of the batch that has poor reception. That could be the cause. I have 17 switches installed and 3 of them won’t join. However the scenes and rules have been working fine.

Oh, have more potential IEEEs been identified? Last I heard it was IEEEs beginning with 38:5B:44 and 94:34:69 that seemed most likely affected.

I will say that in all other ways the switch seems quite responsive so far and has a LQI of 100+, just doesn’t seem to be transmitting “actions” when in a Z2M group/binding.

I believe 94:DE:B8 is fine, I have one from that that’s working perfectly for me.

1 Like

Those are currently the only ones that are affected. I believe the 04:0D:84 is a good batch.

1 Like

That’s a possibility, given the handful of times I noticed that actions seemed to register for a minute or two after grouping/binding. That said, it sounds like my switch is behaving a bit different in that it doesn’t seem to have a “wake” issue for actions when it’s not grouped and when it is grouped, actions don’t seem to “wake up” if I start interacting with the switch again. When it’s grouped/bound, I can attempt 5+ actions in the span of a minute and none seem to come through.

I am a novice when it comes to ZigBee groups/binding, but I do wonder if perhaps it’s an issue with the “action” message being sent to the Sonoff coordinator. When not grouped/bound and actions are properly received, I noticed the action data is part of a message in the “*/action” topic separate from the normal message used to report state changes or light controls. The “action” portion of the larger message does change, but it’s a change from null to “” rather than the action.

When grouped/bound, this separate smaller message with the action data does not seem to come through, even if the larger message does. Is it possible that when grouped/bound, something in the routing prevents this message from reaching the coordinator? I’m not knowledgeable enough about how messages are routed to know if that’s a possibility or not.

hey all,

I have a bunch blue switches in the listed out ieee’s that seem to be affected but I’ve got one that is 04:0d:84.

Using ZHA I’ve gotten it to pair via a sonoff hub. However I cannot get a single or group of lights to bind to the switch. When I click bind I get an indefinite scroll wheel.

Would this be related at all to the issues at hand or something different? the home assistant logs aren’t very fruitful on logging any issues for this.

thanks

It’s actually working in that case :slight_smile: Bind just currently spins, should be fixed in a future update with ZHA (in HA).

1 Like

Got it! sorry if i missed that posted else where in the forms… appreciate your time.

No worries at all, it’s definitely a valid question!