Blue Series 2-1 Firmware Changelog | VZM31-SN

I’m having some issues with the 2.15 update. I have 6 switches. 5 of which took the update fine and are functioning as expected.

One switch, however, seems to be failing to upgrade from 2.14. It seems to be caught in a loop, attempting to update every 10 minutes or so after the green LED stops.

I’ve tried factory resetting the switch, moving my coordinator closer, power cycling everything, but nothing seems to make it stick. As mentioned, the same file updated 5 other switches, but I’ve also re-downloaded that.

As of now, I have pulled the file out of the OTA folder to stop it for now, but if anyone has any insight on how to solve this, I’d appreciate the help!

The warning is just telling you that the driver received a Cluster ID that it doesn’t know about. That is usually because it is not a Standard Zigbee Cluster. In this case, Cluster 0xFC57 is a Manufacturer Specific Cluster that seems to be undocumented at this point.

This does appear to be a new cluster introduced in V2.14 or V2.15. Yes it will require a driver update to fix. But I need more info from the manufacturer in order to update the driver so it knows what to do with it.


Makes sense - Thanks!

How do I manually update firmware via ZHA?

Of course we’re supporting Hubitat users.

We uploaded it the same time as we put it out for everyone. Sometimes Hubitat takes a bit longer bc it’s not the same process as it is for Home Assistant that pulls from our servers. We submit the firmware to Hubitat and then they load it to their servers. So, we’re at the mercy of their schedule.

Hopefully everything is good now that 2.15 is out and in the future, would you mind tagging the other Eric? I am not the firmware guy so it’s hard to keep up sometimes.

So 2.15 is officially out? The ZHA firmware update catalog only goes up to 2.08.

1 Like

Z2M still seems to be pulling images from Index of /firmware/VZM31-SN/Beta and not github. Is anyone working with the Z2M team to update the URLs to the new location? Z2M for me is on their latest version and the latest firmware is 2.08.

1 Like

Can confirm it is not yet released for Z2M.

Been banging my head on the wall trying to force it to update as well. I can say Z2M is not the most user friendly for manual updates LOL

Thanks, I had been checking for weeks and wasn’t getting it, but after I checked again yesterday, it downloaded successfully to my devices. Thank you!

1 Like

I could be wrong, but I think we were waiting to align with the Home Assistant guys on a source for our firmware because we originally had it pulling from the files.inovelli location, but we stopped putting things there because we were trying to figure out some bulb flickering issues and network problems some people were having. And you crazy people on HA (I mean this in a nice way) had auto-updates on when we were still troubleshooting and it was making things worse because we couldn’t tell what the actual problem was (an HA problem or a firmware problem) and it was getting frustrating for us and the engineers.

But now that 2.15 is stable and what we used for production, I think we can work with them again to either continue to pull from the files.inovelli location or have them update to our Github.

@EricM_Inovelli can confirm.

Woke up this morning and my switches are showing update available. :+1:

1 Like

I am seeing updates too but something is off.

You can see in the screenshot that the first two with an available update are on 2.14 which is correct.

The 3rd one was on 2.08 and I ran the update for it this morning. It now shows 2.14 as the firmware but does not show the available update.

Is this because zigbee2mqtt does not know of 2.15 yet so it falls back to displaying 2.14 as the version for switches that are really 2.15?

Maybe update or restart z2m. Mine is updating to 2.15 today.

The update should be available for Z2M and Hubitat users. This version has been tested by several people with good results, but I still recommend that you update one device configuration (ie smart bulb mode, 3-way dumb, 3-way aux, different load types, etc.) at a time and test the functionality that you use before proceeding. There are a few isolated reports of bulb compatibility and a new one about extra reports when using scenes? Blue 2-1 On / Up Behavior (Firmware related?) - Switches / Firmware Discussion - Inovelli Community)

This version makes leading edge the default dimming type (like it was before 2.11). So, if your load is compatible and you want to try trailing edge you can do the button combo of “hold down button then press the config button 13x”. Please only do this if you are using compatible bulbs and are having flickering or other issues. Reach out to us if you need to know if your load is compatible.

@mathd please try this procedure to show the correct version: Blue Series 2-1 Firmware Changelog | VZM31-SN - Switches / Firmware Discussion - Inovelli Community

If you have ZHA and would like to try the update please let me know. I can share the update instructions with you.

1 Like

Thanks for the update @EricM_Inovelli. Glad to see this finally released.

@mathd Z2M has some weird caching behavior that causes incorrect display of version following an update. You can manually confirm the correct version following the link EricM sent. I just did, and it looks like 2.15 installed successfully!

I previously posted here that 5 out of 6 of my switches have successfully updated to 2.15 from 2.14, but one continues to just loop through updating, and failing back to 2.14. It seems like my post may have gotten lost in the shuffle, or there is no information.

I am using ZHA and simply have the update file in my zigbee OTA update folder. I am wondering if there is another method I should try using to try to get this update to stick?

edit: because it may help, I believe that I have snagged the debug log for the entire update process here: home-assistant_zha_2023-08-24T17-41-22.681Z.log - Google Drive

1 Like

This is a bug in Z2M.
Go into the device page, then over to Dev Console.
Endpoint: 1
Cluster: genBasic
Attribute: swBuildId
Click on Read, you’ll see this result

Then go back to the about page and click Reconfigure (yellow button)
It will then display the proper version.

1 Like

Same, in fact most of mine seem to be failing to update on ZHA with the otau folder method.

1 Like

@mathd please try this procedure to show the correct version: Blue Series 2-1 Firmware Changelog | VZM31-SN - Switches / Firmware Discussion - Inovelli Community

That worked, thank you!

1 Like

I’m using smartthings but use HA for updates. Is there instructions to update 2.15? Feel like at one point I came accross them but with the size of the thread now, I’m not sure. Ty