Inovelli Dimmer with Inovelli bulbs not working


I have an Inovelli Red Dimmer and 3 RGBW bulbs, using Hubitat. I have tried a button controller, the Z-wave Association tool to no avail. The button control works “sometimes” wont dim properly and sometime wont turn off. Most time on a light or 2 will go on. I tried the Z-Wave tool it doesnt work at all.

I am wondering if I might have some settings in my dimmer incorrectly set, as the guide for the z-wave tool didnt specify and settings.

For the dimmer:
21 - Neutral
22- load only
52-smart bulb
Disable Local Control - Yes

for the bulb I only have: Enable color pre-staging

Any ideas ?

Did you setup associations 2, 3, and 4 from dimmer to bulbs?

No just 2 and 4, what does 3 do ?

Hmm I can’t remember when I set mine up (moved since then) but thought all 3 had to be associated. Another thing is make sure all bulbs and switch are at the same security level (no security).

1 Like

I just checked my setup and I’m using groups 3 and 4 :man_shrugging:

1 Like

I will try 3 and 4.

I see my bulbs show S0 for all three, however my dimmer shows ‘none’. Are those the same?

Unfortunately no. I’d recommend excluding the bulbs and including with “none” security. S0 has a lot of excess traffic.

FYI, you’ll need 2.31 on the firmware for this.

I thought Hubitat and HA gave you the option to select security level. 2.31 was developed for ST.

Hmmm, that might be. I’m on ST . . .

I didn’t think for bulbs. I had to include mine in a lamp at a distance from the hub so it defaulted to none.

Luckily I am on 2.31. I will try to exclude and include and skip the security.

  • firmwareVersion: 2.31

How in the world do you set the bulb to security none. I excluded the bulb, then did an inclusion, it detected the bulb but never game me the option for security?

This doesnt seem to work:
V2.31 - 02/25/2021

Quickly turn the bulb on / off 3 times to put the bulb into NON-SECURE inclusion mode.

Also, Hubitat will not give me the option for bulbs like they do on dimmers to skip security. Looks like you are suppose to do on/off 3 time during pairing for non-secure mode, I cant get it to work, tried 20 times.

@harjms is on Hubitat, so maybe try his technique?

I think I am just going to return the bulbs, these just dont work very good at 3 times the price of something like Sengled bulbs. Too bad inovelli bulbs dont work with inovelli dimmers kind of a bad business model if you ask me.

Because they don’t work for you doesn’t mean they don’t work for others. I have 10+ working flawlessly for years in my Home Assistant installation.

You don’t need to disable local control either.

Set switch to smart bulb mode 2 (smart bulb mode) and it keeps power on 100% of the time regardless of dimmer state. Then get the same security (none recommended), then associate 3 and 4 from dimmer to bulbs.

Understand if you are having an issue, but help will come I can assure you.

Understand, however I can not get the bulb into ‘none’ security mode, looks like the firmware update (2.31) that allows you to do that is only for ST.

I have tried a million times to get the bulb into none security mode, the firmware directions say during the pair do on/off 3 times quickly, this just doesnt work for me, it pairs the bulb in S0 mode. I then have to exclude and try again. The exclude doesnt work very well as when it excludes it just says ‘Unknown Device’ and now a have a bunch of ghost nodes because the exclusion isnt very clean.

Sorry, I should’ve been on top of this. Here are instructions (I know it’s for ST, but it will show you the cadence of how to do it).

I haven’t written instructions for Hubitat yet, but the video (starting at 0:22) will show you the cadence of how to get the bulb paired with no security.

1 Like

Thanks so much Eric, it finally worked.

Non-Secure via HE

  1. Turn bulb off
  2. Devices - Add Device - Z-Wave - Start Z-Wave Inclusion
  3. Follow cadence - Turn bulb on then count 1 Mississippi, off 1 Mississippi, on then count 1 Mississippi, off 1 Mississippi, on
  4. rapid 2 bulb blinks, follow by another blink about 5-10 seconds later.
  5. Name and Save device
  6. Settings - Z-wave Details - Look for your new bulb, check Security Column for None. If it says S0, exclude and try again.


To use the Z-wave association tool, what device settings do I need for the bulb and switch:

I am assuming:
For the dimmer:
21 - Neutral
22- load only
52-smart bulb
Disable Local Control - Yes

Enable color pre-staging