lzw30-SN 3-Way setup not working (parameters needed?)

Hi All,

I have a red inovelli switch (not dimmer) set up in a three way like so:

I’ve triple checked to make sure everything looks right. When I turn off the dumb toggle switch at the other end the light turns off. If I turn the switch back on immediately it is fine, but if I wait a few seconds I eventually hear the inovelli ‘click’ off at the first location. If I then try to turn the dumb switch on nothing happens.

If the dumb switch is off, and a I try to turn on the inovelli switch it clicks on and immediately clicks off.

I’ve tried looking to see if I need to set the red switch to three way mode, but I don’t see anything in the manual about a three way parameter to change to (where it is pretty clear with the dimmer)

I’m using home assistant.

Any ideas? Should I quadruple check my wiring?

It never hurts to double-check the wiring. If you post pics we’ll take a look.

Unlike the dimmer, the switch is supposed to auto-detect it’s configuration. It may not always do that well, though. There is a firmware update, at least in Beta, that is supposed to address this. One of the firmware addicts like @harjms or @Terk can weigh in on this.

An alternative would be to swap out the dumb switch for an Aux.

The firmware update is worth the selecting single or 3/4 way. Several people have reported great success with it.

I have three LZW30-SN in 3-way setups, all using GE add-on switches, two of these setups (one florescent tube and the other three LED bulbs) work both on and off at either side the other one will only turn on using the add-on switch not off but the main LZW30-SN switch always works either on or off.

I have updated all of my switches to 1.17 but when i tried the Special Load (T8) option it wouldn’t turn on from the add-on switch any longer but would turn off however it would leave the LZW30-SN thinking it was on even though the relay had turned off so nothing would turn it back on (physical on either end, Z-Wave, or Alexa) until i turned it off and the light on the switch would get dim to indicate its off. Then the LZW30-SN would work as normal again until the add-on was turned off again.

After changing the Special Load option back off I had to airgap the LZW30-SN before the add-on would do anything again and it was back to turning the light on only but at least didn’t cause issues with the LZW30-SN. This switch controls 4 LED floodlights so I don’t know if it’s an issue with the bulbs or the add-on switch my guess would be the bulbs but I don’t really want to get more just to find out.

So sounds like this is a bit of a glitchy scenario here! Does anyone know if a generic momentary switch like


Work in a neutral setup? Would this be a better option? All of my other installs use the GE add on switches which work beautifully, but the GE add on switches are kinda expensive…

I had the same situation as the OP. LZW30-SN in a 3-way setup with a dumb switch. Depending on the state of the dumb switch, the light would stop turning on or off or only work sometimes. My firmware was showing as 1.20, which seemed to be the latest version. The docs still show 1.19 as being the latest beta, although if you go here, there is now a 1.22 in beta: https://files.inovelli.com/firmware/LZW30-SN/Beta/

One slight difference from the OP is that I had both the Line and Load wires in one box. However, I triple checked everything and was pretty confident that my wiring was correct. I’m using Home Assistant with the OpenZWave beta as my hub. There was no parameter available in the User Config section in order to specify a 3-way mode. I also tried holding the config button for 10 seconds until the LED turned yellow and then pushing the config button 13 times. I could never get it in the state where the LED would blink yellow slowly once and then three fast blinks. I probably tried this 10 to 15 times. Finally, just as something to try, I did change the Load Type to “Special Load” and all of a sudden the switch worked correctly no matter the state of the dumb switch.
I wish the documentation would have been up to date. Probably would have saved me an hour of troubleshooting.

1 Like

Should probably be captured in the changelog @EricM_Inovelli. Also maybe change the name and remove T8? Just say Auto or Manual?

1 Like

I’m having the same problem dreyln described above, where depending on the state of the dumb switch the inovelli switch will either not work at all, or turn off then back on immediately. In some situations, I can toggle the dumb switch and hear a click on the inovelli switch (the lights stay off), then I can toggle the dumb switch once more to turn on the lights successfully.

Setting parameter 13 to 1 did not fix my problem. My switch is currently on v1.22, but I also tested on v1.21 and v1.19 with the same results.

im kind of having the same issue. My lzw30 -sn will pair, albeit briefly, and then just disappear from HA. Like it just stopped working. The light still works however, but the zwave just drops connection. I have a strong mesh network with a few powered devices over on that side so it can’t be the mesh I"m just not sure if its the wiring. My firmware, when it did connect, said 1.21.

Your situation sounds exactly like what I spent 6 hours troubleshooting last night and today on a new switch install. Sometimes switch would work as expected, sometimes it would only work if the dumb switch was in a certain position, sometimes the light would shut off and then turn right back on. At first I just had a Red On/Off switch and so I started looking for the 3-way parameter and couldn’t find one for On/Off. So, I swapped the switch with a Red Dimmer and set the parameters correctly and it had the same issues! After a bit of research, I started seeing talk of “Special Loads”. I don’t have anything fancy, just a single light bulb on this circuit. It did get me wondering if the Light Bulb could be the problem though and sure enough, I swapped it with a different one and the switch now works as expected. How frustrating to have spent so much time troubleshooting because of the stupid bulb. haha. Glad it’s working now.

Sharing my experience here in case it might help someone…

I spent 1/2 a day trying to figure out why my aux switch and then dumb 3-way switch were both having issues with the LZW30. With the aux switch I was experiencing the aux turning on the LZW30, but not off. With the dumb 3-way I was experiencing the LZW30 turning back on after physically turning it off (at the LZW30). Same issue through the hub (off resulted in the LZW30 turning back on within a second). I upgraded to firmware to 2.20. No improvement. I set parameter 13 (Load Type) to Special Load (T8). No improvement.

Then… I decided after reading numerous threads of people experiencing the same issue and responses that the LZW30 is supposed to auto-detect a 3-way circuit, that I would try replacing one of the 3 LED bulbs on the circuit with an incandescent. Bingo! the 3-way circuit worked. Problem identified… the LZW30 needs a load greater than what the LED bulbs were creating in order for the LZW30 3-way auto-detect to work. Since I’m not going to live with a mix of LED and incandescent bulbs, I’ve installed a load resistor (similar to what is needed for some older dimmers after swapping to LED bulbs). I use the Aeotec version, but there are others out there. Google “Aeotec bypass for nano dimmer”.

The resistor connects “across (or in parallel)” with the light (or outlet - if that is what you’re controlling) itself, thus creating constant resistance on the load (which is what an incandescent bulb would do). You can wire the resistor at the LZW30 itself by connecting one of the resistor’s leads to the Neutral connector, and the other resistor lead to the Load connector (along with the wires needed for the circuit - as seen in the Inovelli documentation).

I’d like to see a firmware update which forces the 3-way config (doing away with auto-detect). I’m not really enjoying dropping $15 on a load resistor to solve the problem.

Hope this helps others. Cheers!

I’ve had this same problem with a couple of three way lights in my house and I’ve found that different bulbs “work” and some “don’t work”. I’m not sure if it is because some bulbs naturally have more resistance than others or what but it has made it really difficult for a couple fixtures to make work in a 3 way setup. If there is any way to add this firmware update to force 3 way config (no autodetect) it would be a huge help!

1 Like

This! Same issue here.