LZW31-SN Internal Relay Disable - What's the point?

I recently installed a bunch of Red Series dimmers and some are controlling smart bulbs, so I disabled the internal relay (8 clicks of the config button, see the LED blink red). After doing so, the button paddles don’t do anything. When I turn the switch off via Smartthings, it still kills the load output. Press and hold no longer sends dimmer commands to the hub.

So what exactly is the point? This seems like a broken/useless feature to me, but I’m hoping I’m missing something. Any chance it’s been fixed in a firmware update?

It seems like I’m going to have to pull the switches controlling smart bulbs and disconnect the load and hardwire it to the line in the box rather than via the switch as I expected. Again, hopefully I’m missing something and that isn’t actually the case.

So when you disable local control, the dimmer provides constant power to the smart bulbs, which as you know, is what you want. So now the switch is constantly powering the bulbs and you can’t turn them on and off via the switch controlling the power to them. That is exactly what is supposed to happen.

At this point, you can still turn the dimmer off via ST, which you discovered. You don’t really want to do that, though, because you don’t want to cut the power to the bulbs. A lot of users are satisfied with the protection at the switch but if you don’t want to be able to turn the lights off accidentally via ST, then you also need to disable remote control.

You have a couple ways to control your smart bulbs with these protections in place. You can either use association or scenes. Take a look at this for a discussion of both:

Please correct me if I’m understanding wrong.

So basically the “disable internal relay” nomenclature is incorrect and misleading. The function is really “scene control only” function. Calling it “disable local control” is closer, but still misleading to say that’s what you need to do to use smart bulbs with it (as using the dimming or on/off functionality via the hub still changes the voltage on the load output).

Side note, at least with ST, enabling this mode makes the LED useless as it won’t change to reflect what the status of the lights is. It’ll just stay at whatever color/intensity it’s configured to be at forever (assuming you don’t muck around with on/off or dimming controls via the hub).

If I’m correct, it isn’t a huge deal, just a bit disappointing because it means I have to pull those switches from the walls and tie the load directly to the line, leaving the load output of the switch disconnected. Then I can leave the relay on and maintain all the functionality of the switch that I thought this “disable internal relay” mode would give me while still being able to disconnect load voltage with the disconnect tab on the front of the switch. Oh well.

Disable local control… disables local control of the switch. Tapping the switch does nothing
Disable remote control… disables control of ST on the switch. Changing the state in ST does nothing.

I also recommend setting the restore state to 100 (will turn on when power is restored). This will prevent you from having issues with the bulb being offline when power is lost.

Once done, you control the smart bulb directly. Turn the bulb off, turn the bulb on, change the color, change the level, etc.

If you want the switch to perform actions on the bulb you have many options, but I have associated groups 2 and 4 for dim and on/off control. Another option is going through the hub using ABC controller if you are using zigbee or wifi smart bulbs.

The vast majority of my bulbs are relatively simple adjustable white Zigbee bulbs. I don’t care about RGB so haven’t spent the extra money necessary to get that yet.

At the end of the day, for the dimmer to act like anything other than a simple scene controller for Zigbee or wifi bulbs, I need to not use the “disable internal relay” feature and hardwire load to line (leaving the load side on the dimmer disconnected). Not a huge deal, just annoying and frustrating since these are marketed specifically for use with smart bulbs and the words “disable internal relay” insinuate the exact functionality I’d hoped for (keeps constant line voltage going to the load, but sends on/off/dimmer commands to the hub).

Hey @Aegwyn11 – maybe I’m not understanding correctly. Can you clarify what you were expecting here when you said this?

They do, in fact, provide constant power to the load. I’ll have to confirm with @EricM_Inovelli around the sending on/off/dim commands to the hub for non-Z-Wave bulbs, but even if they don’t, they will send a Central Scene Command to the hub, which will help for non-Z-Wave bulbs.

For example: if you use a non-Z-Wave bulb, here’s how you would set it up:

  • Create a scene to where you can turn on/off the bulb via Button 1 (in other words, you tap up on the switch and it turns the bulb on and you tap down and the bulb turns off)
  • Create additional scenes where you can set the bulb to various dim levels via other taps (ie: double tap down = bulb is set to 50% dim, triple tap = bulb set to 25%, etc)

For Z-Wave enabled bulbs you can do exactly as you’re wishing. I have this exact setup at my house. It’s a 4-Way setup with 2x aux switches. I’ve disabled the relay on the main switch and Associated Groups 2 & 4 so that I have On/Off and Dim control from all three switches.

Can you let me know what you’re wanting to do?

To answer your other questions:

I’m not sure what is misleading about this and apologies if it came off that way. You are literally disabling the internal relay so that there is constant power to the bulb. Local = at the switch… Remote = via ST app (or whatever hub you’re using). I’m open to a better explanation – but we’ve laid it out pretty clearly here, right?


Thanks for the response. Unfortunately much of what you described isn’t how my switches are working. Here’s what happens.

  1. 8 taps of the config button, led blinks red confirming “internal relay disabled” mode is on.
  2. Switch paddles now do NOTHING. Press and hold for dimming function doesn’t send anything to the hub as far as I can tell.
  3. Using ST to change on/off/dim level status of the switch ABSOLUTELY changes the output of the load side of the switch. Turn he switch off in ST and there is 0 voltage coming out of the load side of the switch.

As such, even if I wanted to use them as scene controllers with ST and my Zigbee bulbs, the LED on the front of the switch would just have to stay static forever and wouldn’t reflect the status of the lights. Unless there’s some trick I’m not aware of.

Of course, if everything I’m saying is bull because it’s been fixed in a firmware update I need to apply, GREAT! I’m all for that (even though I just got these switches a month or two ago). But at least for whatever firmware is on my switches, the 8-tap of the config button thing only makes it so that the paddles on the switch don’t send on/off/dim commands to either the load side of the switch nor the hub. That’s it. Nothing else. It certainly doesn’t actually disable the internal relay.

Yep, that is essentially what it does, but there is just some extra flexibility. Using associations you can send on/off/dimmer commands directly to Z-wave smart bulbs.

If you want to use the switch like a scene controller for non-z-wave bulbs then you assign the button presses to actions at the hub. For example:

up button held = dim these bulbs up
up button released = stop dimming
down button held = dim these bulbs down
down button released = stop dimming
single press up button = turn on bulbs 99% 2700K
single press down button = turn off bulbs

You can even get crazy after this point with double press, triple press, etc.

One caveat is that the sometimes spotty speed with SmartThings makes the button held / release commands have a delay so you may want to assign something like:

double press up = set to 50% 2700K
triple press up = set to 25% 2700K
or something like that.

If you have a local system like Hubitat the commands are very responsive and act like you would expect.

Edit: In regards to your other post:

This is certainly an interesting problem to overcome. We have been working on a way to accomplish this, but there are some hurdles here. Like, what does the LED display if there are 3 bulbs attached and one is at 33%, one at 45%, and one at 99%? How does z-wave switch know what the level is for a zigbee bulb or a wifi bulb? What if the bulbs aren’t even attached to this load, but it is just being used as a scene controller? What happens if two of the bulbs are turned off but one of them is on? Does the LED bar stay on or go off? These are just a few examples that are involved in engineering this feature, but one that we are working on.

This just isn’t true. If you have the LZW31-SN (title of the post) then it does send on/off/dim commands to association groups 2 & 4 and sends an assortment of scene commands that can be interpreted by you hub to do whatever you would like. ie dim/on/off. The “relay” no longer opens or closes when controlled locally.

Then why don’t these switches work this way? This is EXACTLY what I expected and NOT what I’m getting. These switches came in the four packs with the pair of Ilumin bulbs. The model number in the title matches the ID on the back of the switches.

I just did a test. First, turned “internal relay disable” mode off and back on (8 taps, led blinked three times red, paddles do nothing now).

Single down tap doesn’t show anything on the switch device in ST. It just stays “on” in the app.

Single down hold doesn’t show anything on the switch device in ST. It just stays at 99% in the app.

Voltage at the load side now is sitting at 115V.

In the switch device in ST, I set the dim level to 50%. Voltage at the load side is now about 60V (and my Zigbee bulbs are blinking angry because the voltage is too low). Also, the front panel LED reflects the dim level being at 50%.

In the switch device in ST, I set the switch to off. Voltage at the load side is now about 9V. Front panel LED is also off.

What am I doing wrong?

BTW being told that I’m lying by saying “this isn’t true” is very off putting. Tell me what I’m doing wrong. Don’t tell me I’m lying.

Ok after re-reading this response again, I realize that after you told me I was wrong, you restated exactly what I said in different words. The thing that 8 taps of the config button does is disable local control using the paddles except for Z-wave bulbs. For those it does something different.

So I’m back to my same solution. Forget this silly mode that has a nonsense name and just physically disconnect the load side from the switch and physically tie it to the line side. Done. On/off/dim messages still go to my hub and work properly with my Zigbee bulbs. And I can use scene control to boot using the multi tap functionality.

Just because you mispoke doesn’t mean you are intentionally misleading people. In other words, I’m not saying you are lying, I’m just saying your statement isn’t true and I am trying to help you understand why it isn’t true. I don’t think you are being malicious, I’m just trying to help you.

Sorry if it came off that way.

It is actually best to either enable “Remote Protection” in the settings or not control the switch via SmartThings. As for how to get things working we have written up some great information that should help get you started:

Edit: I noticed that @Eric_Inovelli already mentioned the last article. Have you had a chance to give it a shot? Are you getting stuck somewhere that we might be able to help?

1 Like

I have read through all this and if I had Z-wave bulbs, I’d be set. But I don’t (for the most part, except for the four I got as part of these kits along with the switches). So, let me ask one very simple yes/no question:

With Zigbee bulbs connected to the load output of the switch, is it possible to set up dimming so that up/down press triggers a bulb or group of bulbs to dim in response?

If the answer is yes, please direct me to the how. I believe the answer is no and that to get that functionality I need to have the bulbs hardwired to the line input (leaving the load side of the switch disconnected).

There must be a misunderstanding here. I am reading all of this and you are clearly implicating that the switch is not CAPABLE of doing what you want it to do, when it definitely is. I do it myself. I personally have many zigbee dimming color control lights that I operate on/off and dim via the red dimmer switch.

Start here:

  1. Disable local control
  2. Disable remote control

Now the switch does nothing and will not allow you to change via app, right? Ok good. We want constant line voltage (110-120V) to the bulb, and we don’t want anyone changing that.

Now depending on the type of bulb, there are multiple solutions for “smart” communication between the switch and the bulb.

  1. Z-Wave - Download the Z-wave association tool and group the switch as master and the bulb(s) as slave in group 2, and a second association on group 4. Note that there is a 5-slave association limit.

  2. Other - 2 options

2A) Use 3rd party software “ABC Controller” or equal that will translate press at the switch to an action at the bulb.

2B) Set a scene with the bulb at a specific level/color as desired and set up central scene commands with the switch. One up = one up scene, One down = one down scene. One scene per tap count up or down.

I believe you still think the switch needs to regulate voltage in some way, but the ONLY thing the switch will do is send it’s press (tap up) or held (tap down) or true held commands (see the button mapping, other thread) to the bulb if z-wave (quicker) or through the hub, then the hub will make the corresponding change at the smart bulb.

Note that even in an “off” state, the bulb has full 120V. The bulb itself is just off.

1 Like

First, sorry for getting off on the wrong foot here with this – we by no means mean to be insulting you, just as, I’m assuming with your quotes above, you weren’t trying to insult us. It’s hard to tell the inflection of tone/voice via written words, so I think that’s where the communication breakdown occured.

Anyway, let’s start fresh. It sounds like this is what you’re after, correct:

I’m guessing what you want to do here is hold up on the paddle and your Zigbee bulbs will dim up in realtime and when you hold down on the paddle, they will dim down in realtime (or as close to realtime as they can since they are technically wireless).

If that’s my correct interpretation, to my knowledge I’m not sure it will work on SmartThings in that way. However, maybe @prjct92eh2 and/or @jody know of a way to do this.

There are a couple of threads discussing this for Hubitat (I know you’re on ST, but I at least wanted to show you that it is possible to do what you’re asking) but again, even on Hubitat, there will be a slight delay.

So, as a workaround as Eric and @kreene1987 have suggested, we’ve put together a couple other options for you for non-Z-Wave type bulbs as outlined in the SmartThings links above.

Hopefully that helps clear up some things for you and again, apologies for the misunderstanding – let’s just figure this out for you and/or try to work towards a solution.

For my own help, where can we be more clear about the limitations and/or implications of how switches work with bulbs? I wrote up a bunch of Knowledge Base articles, but maybe people don’t look there? Honest question – one of my goals has always been to try to be as clear as possible (sometimes to a fault), so I’m curious where we can improve.

More than happy to help with my input.

Like, what does the LED display if there are 3 bulbs attached and one is at 33%, one at 45%, and one at 99%?

I would look for the “mean” of all bulbs, so (33+45+99)/3 = 59

How does z-wave switch know what the level is for a zigbee bulb or a wifi bulb? What if the bulbs aren’t even attached to this load, but it is just being used as a scene controller?

This I can see as being a challenge, but you should only be worried about functionality of z-wave to z-wave stuff that is associated.
For other (zigbee, wifi, etc) I would basically look for a second setLevel command (barLevel?) of the switch that would be in the DTH that I could essentially overwrite the LED “height” and intensity. I would basically send the command from the switch being tapped down (off) to set the bulb and the bar level to 0 (which would then go to “off” state of solid 10% intensity).

What happens if two of the bulbs are turned off but one of them is on? Does the LED bar stay on or go off?

Again, the mean of the 3 is 33% (assuming (0+0+99)/3 is the evaluated mean). It should be on, but representing a level of 33% as there is 33% of the possible light being utilized from that switch.

These are just a few examples that are involved in engineering this feature, but one that we are working on.

Can’t wait!

1 Like

You’re using the Z-wave tool to slave Zigbee bulbs to the switches? If that’s the case, that’s where I’ve been confused…the way I read the links sent by the Inovelli gents seemed to indicate that non Z-wave bulbs would be stuck with just scene control and I couldn’t figure out how to use that to do dimming via up/down press and hold with local control disabled.

In your setup, do the LEDs on the switches change at all? Or are they static at whatever setting they’re configured to, never changing?

Thank you for the candor. IMHO, “disable internal relay” is confusing and misleading nomenclature. The terms in the ST DTH (disable local control) are still imperfect because of how you can directly pair the switch to Z-wave bulbs, but it’s better and less confusing/misleading for the uninitiated like me. At least for me, the words “disable internal relay” insinuate that line becomes hardwired to load internally in the switch, allowing it to still be wired “correctly” in the box but also maintaining full voltage to smart bulbs.

Pending @kreene1987 's response to my questions above about dimming, Zigbee, and ST, I might have to consider forgetting about dimming until I yank ST and replace it with something else (leaning towards HA right now). Or I just pull the switches and hardwire line to load like I’ve mentioned.

No, for zigbee devices I use Option 2A, which is ABC controller. This was originally supported by Inovelli and recommended by them. I’ve installed it in the IDE via smartapps, so it only works in the Classic ST app.

No worries – happy to improve where we can.

Maybe I’m confused, but this is exactly what it does. I must be missing something – it’s early in the morning lol!

When you turn on your switch and disable the relay, you are disabling the ability to turn the switch on/off and providing full power to the load at which it’s attached to (ie: smart bulbs).

Eric, I’ll add that this had be confused for a long time as well.

I believe “Disable Local Relay Control” and “Disable Remote Relay Control” or similar would have been more clear to me when setting up my first switch.

1 Like