Notifications Stopped Working

Some time ago, notifications on my switches (both black and red) stopped working. If a garage door was open, the LED bar would chase red, if a basement window was open, the LED bar would blink green, and stuff like that. They suddenly stopped working, and I have no idea why. I’ve tried deleting a notification and creating another one, with no success. My hub is a Samsung SmartThings hub.

Any thoughts?

Edge drivers or Groovy?

Post the automation that drives the notification.

Groovy, at least I think it is. I just learned of Edge today, and I’ve had these switches installed for a few years.

Black switches don’t support led notifications.

I still have some red switches on Groovy DTHs and the notifications still function.

Are you using a child device to turn the notification on and off? Try turning that child device on manually and see if your notification fires.

Not child devices. One notification is for when a garage door is open, and the other is for when a main floor window is open. I have another one for when a basement window is open, but I’m confident that doesn’t work either. I do get other notifications/actions when those events occur, just not the visual one via the LED bars. They used to work fine up until several months ago.

These notifications were setup via the Smart Lighting section of the app.

Groovy devices use child devices for notifications, so if you are on Groovy that’s not tracking.

Also, are you on the old or the new Smart Lighting?

Let’s go one step at a time. For one of the switches on which you want a notification, post a screenshot of the device’s page in the app with the 3-dot menu expanded.

1 Like

I didn’t know which of the 4 options you wanted, but I thought this was the most likely:

I actually wanted to see what the options were but this is fine. I can see that you have a Driver menu. This means that the switch is using the newer Edge driver and not the older Groovy driver.

Since you just learned about Edge drivers, I am going to presume that you did not convert the switch yourself. Smartthings is in the process of autoconverting devices from Groovy to Edge, so I am guessing that Smartthings converted it for you.

So when that happened, Smartthings loaded its generic driver. But for the Inovelli advanced features to work, you need to be using Inovelli’s Edge driver. So that is why you’re notifications are no longer working.

You will have to join the Inovelli Edge channel, link below, and then switch to the Inovelli driver. You should then be able to access the advanced features such as notifications. My recommendation would be to remove your old notifications from Smart Lighting and re-code them using Routines.


Oh, the options are Edit (name, icon, and room), Settings, Driver, and Information.

You are correct about Smartthings converting my devices. I’ll join the channel this weekend (when I will have time to play with it) and install the driver then.

One of my switches has a couple of ZigBee lights connected to it. I have never been able to operate the lights via the switch (it wasn’t that big of a deal to me when I installed the switch – I could just tell Alexa to turn them on). Will this new driver make it easy for me to do that.

Thank you so much for your help.

Get the driver loaded and report back. We can work on that next.

So, I installed the Inovelli driver on all of my Inovelli switches. Went into Smart lighting, and that notification was no longer there. All of the other stuff was, just not that one. Went into Routines in the switch I’m dealing with and the first thing I noticed was that in the main window of the switch, only “Notifications” was listed. Tapping on the settings wheel, the only thing I could do was select the type of notification (pulse, chase, fast or slow blink, etc. Previously, in the main window for the switch I could select the color, type of notification, etc. for each of the 3 notifications. This seems to be a huge step backwards as it seems I can no longer have 3 different notifications, each with their own color. I used to be able to look at it and identify (at a glance) whether a basement window was open or a garage door. Now, it seems that it would be merely “something’s open.”

Because I had 3 notifications setup previously for this switch, in my app I have 3 notifications icons. Tap on them, and the only thing I can do is edit the name and icon – nothing else.

In Routines, I set it up so that if the garage door is open, Notification 1 would turn on. I have notifications set to chase. Opened the garage door, and the main lights came on. No chasing on the LED bar.

I’ve verified several times that the driver is the Inovelli Edge Driver.

It’s a slightly different approach now, but you can have as many notifications as you like for a given switch. Notifications should be set via routines, not via the device’s page.

Start with the routine and select the trigger for the notification. In the THEN section, select Control Devices and select the switch you want the notification on. In the following screen, select a setting for each of the four Notification items. Make sure you set all four. (By default, Turn On will also be selected. Press it to deselect it.)

Rinse and repeat for additional notifications on the same switch.

It’s actually much cleaner under Edge, but just approached differently. Most importantly, this accomplishes notifications without child items, which is beneficial if your device count is high.

Setup as directed. When a door is open, the lights on that switch come on – nothing on the LED bar (well, the solid aqua (switch’s color)is there but not the chasing red (notification’s color)). Do I need to delete Notifications 1, 2, & 3 from my app? They are listed as devices. Might that be causing a conflict?

1 Like

I’m sort of getting somewhere. Tried deleting “Notification 1” from another switch, and the test notification came on. Didn’t go off when I closed the door, though. Then I went back and deleted Notifications 1, 2, & 3 from the Main Room Lights switch, setup the routine again, and the main room lights still came on, but so did the notification. Went back into the routine and enabled the dimmer and set it at 0. Now, it comes on as it should, but doesn’t stop when I close the door. Previously, there was an option to stop notifications when the conditions were no longer met (door was closed), but not now – you select a time or indefinitely. I thought creating a routine that would turn off the notification when the door was closed would do the trick, but when it’s enabled, the notification doesn’t come on when the door’s opened. Turn off the new routine, and it comes on as it should.

Yeah, it is not supposed to. You just coded turning it on. You also have to code turning it off. Use another routine for that.

Did you turn off the Turn On part of the routine? See my note in parentheses in the second paragraph, above.

I tried creating a routine that would turn off the notification when the door was closed would do the trick, but when it’s enabled, the notification doesn’t come on when the door’s opened. Do I need to do a short delay in the turning on routine?

You shouldn’t. I have a number of these all coded the same. If contact = open then set 4 notification parameters. IF contact = closed, then notification effect off.

Can you post the two Routines so we can take a look?

The notification on open door worked for a while, and when I added the end notification on door closed, the bar stopped blinking, but no LED bar at all. Now, with this setup, I don’t even get notifications.

Those routines look correct, with the exception that the turn off the notification has been removed from the closed routine.

I would look at the history for your contact sensor to see when it is opening and closing. Line that up with the actions that you’re seeing.

I don’t see any reason that you’re notification turning on should not work at this point. But take the delay out of it in the event that the contact sensor is doing something weird. That way the notification should turn on right away when it’s open.

Also, as I suggested before, take the main room lights turning on and off out of the routine. I believe that selection is killing the notification.