Switches Freezing Issue - Data Collection Thread

Hey all,

There seems to be some sort of issue with switches freezing up and needing to be reset via the air-gap.

See threads:

We’d like to start figuring out a root cause of this as it’s very strange and we’ve not been able to replicate this in-house.

If you are having this issue, can you please let me know the answers to the following questions?

  • What Product(s) are you using (LZW30 - On/Off Black Series, LZW30-SN - On/Off Red Series, LZW31 - Dimmer Black Series, LZW31-SN - Dimmer Red Series, etc)?
  • What Hub/Gateway are you using (SmartThings - V1/V2/V3, Hubitat, etc)?
  • What Load are you controlling (LED, CFL, etc) and what is the approximate Wattage?
  • Are you controlling a Smart Bulb?

Lastly, and please do not share this publicly, we’ll reach out to you via PM. Can you follow this guide to share with us your SmartThings Device Info (if using ST): https://support.inovelli.com/portal/kb/articles/how-to-find-your-device-info-for-troubleshooting-smartthings#Finding_Your_Device_Information

Again, please do not share that publicly. I’ll look for whomever comments and reach out to them privately.

@gijosh28 @KuLe @dj13990 – tagging you guys as you were the latest to experience this.

UPDATE: We’re going to purchase and send out some Zniffers to anyone that’s willing to help with this issue. Our manufacturer and us have been stress testing switches for weeks and have not been able to replicate this issue, so we’d like to open it up to anyone who is having this issue.

In addition, we will be putting together a group of people via our Microsoft Teams account to speak directly to the manufacturer (we use Teams with them) via chat to see if we can solve this.

Anyone interested, please shoot me, @EricM_Inovelli and @Courtney_Inovelli a PM so we can get you setup in Teams and send a Zniffer to you.

Hey Eric,

  1. LZW30-SN - On/Off Red Series and LZW31-SN - Dimmer Red Series (I also have the LZ30, but have never had an issue with them)
  2. Hubitat
  3. 2 LED bulbs. They are your RGBW Bulbs (not sure on the wattage)
  4. Yes your RGBW Bulbs

A few things I have figured out. I noticed that when both of them would freeze it would be soon after I included another zwave device in the network. Didn’t matter what it was or how far away it was, this seemed to be the main trigger in either of them freezing. Then the Dimmer would just stop working every few days. It is associated with your bulbs and local control is off. I did after the firmware update reset it and reset all rules that included the dimmer. I did this to make sure I didn’t have something that was powering it down remotely or something. Since the update and reset my dimmer is still good Hasn’t frozen in a few days now. I will keep checking it and report back on it. I updated the firmware last week. My switch has been good also since the firmware update. Both of those I had a hard time getting the firmware to update, but once I did they seemed to calm down. I haven’t included any new devices since the day after and I did have the dimmer freeze that day. I may later this week reset a wave device and include it and see if it causes the same issue.

Hope this helps

1 Like

LZW30-SN - 1 switch 1x lockup resolved w/airgap.

ST v2

LED, 2 60W equiv dumb bulbs, about 12W I guess. Not controlling a smart bulb.

1 Like
  1. LZW30-SN - On/Off Red Series
  2. Hubitat
  3. LED 4 foot tubs in a garage. (6 pair) (about 90 watts total)

I thought I had a bad switch as was thinking about contacting you but then seen this post. I have a rule that when this turn on or off, turn on or off another outlet in my garage (Overhead work light) And it will turn on and off, but the main lights do not. The relay does not seem to trigger every time. and the air gap does not always fix the issue the first time. I have to air gap it and then on off on off on off several times and them air gap and then i starts working again. Its completely random when it happens.

Some times it has happened a few times in a week, then it might go a few weeks without any issue.

Now this switch gets used alot, it auto turns on and off alot also with a rule based on motion. I go out there several times a day (5-10 times) so the switch is highly used.

1 Like

Just a follow up, Haven’t had a freeze again, Maybe the firmware or maybe the reset fixed it, but none of the switches have had an issues. I did just order some new dimmer (May the 4th be with you sale) so I’ll let you know if they cause any issues when I add them to the network.

1 Like

LZW30-SN - Newly installed switch 1x lockup resolved w/airgap.

ST v2

Installed the switch and noticed it locked up about 5 minutes later.

Controlling under cabinet xenon lights . . 100 W??

Will keep an eye on it.

Hey @Eric_Inovelli

Update on the issues…

So I received my new dimmers and switch. I installed the two dimmers and the first one I included I updated the firmware before doing anything else. The second I installed and did not update the firmware. I also had all other switches in my house updated. Everything worked great and then the new switch that I didn’t update the firmware froze. I pulled the gap and then updated the firmware and everything is ok right now. I’m thinking this is the old firmware that is causing the issue. I’ll give it a few days to see if any others freeze now that I added 2 new dimmers.

Been a little over a week and I can say that none of my switches are giving me a problem. The new firmware I think solved the freezing issues I had. Thanks!

1 Like
  • What Product(s) are you using: several LZW31-SN though I only have experienced the lockup issue with one of them (and continue to experience it)
  • What Hub/Gateway are you using: Hubitat
  • What Load are you controlling: in this troublesome case it is a few dumb LED, total wattage on that circuit is 32W, I did try swapping to halogen to see if that had any effect but I still managed to experience a lockup
  • Are you controlling a Smart Bulb: no smart bulbs here

A few other details that might be relevant:

  • there is a neutral present
  • I initially thought that the problem was the config button interference issue but I doubt that at this point
  • first experience with the issue was running firmware 1.41, after updating to firmware version 1.43 the issue persists
  • air gap reset fixes the issue every time

Now to the new clue experienced this morning — after this most recent occurrence I thought to check the Hubitat driver and logs before performing the air gap reset. What I found was the parameter “Disable Local Control” had been switched to “yes.” Performing an air gap reset does fix the issue and restores this parameter back to “no” as it was originally set by Hubitat. If the issue occurs again I will check this to see if it repeats.


I am still having this problem, and when one of my switches locks up, automations from the hubs stop working. I reset the airgap switch on the affected switch (after figuring out which one it is) and all the previously locked automations all run in order. I have also found that I can cause the issue, if I play with setting one of the dimmer’s percentage too quickly in the SmartThings app. I think this is a logjam issue. It seems to happen when I disarm and arm the house too quickly. Like a z-wave command to turn off a switch comes too quickly after a command to turn on a switch. Then it never gets reported and the switch locks up. Then the rest of the scene and all subsequent automations are locked until I reset the airgap. It also seems to happen more frequently when I add the second hub. I think the jam starts with an errant status report from the switch.

I was PM’ing someone about this, but the dialog stopped.

Have you guys identified the issue yet? Do we have a way forward for fixing this?


Update to this thread — I can confirm that the issue still is ongoing for me. Recently it only seems to effect one dimmer in my home though I have seen the issue in every red series dimmer I own at one point or another. More details:

  • as I described in post 12
  • the issue does seem to associate with the switch somehow disabling local control and it is possible to confirm this by checking the Hubitat device page
  • airgap resetting is a 100% reliable way to return the switch to normal operation

Hey all – just posted an update – this is top priority for us right now as we are working towards mass production on a second batch of switches and would like to figure out what’s happening.

1 Like

Hello @Eric_Inovelli

So today I just had a black series switch just stop working. I thought it was a freeze issue and was getting ready to post, but I figured out it was just dead. Nothing would revive it, I even killed the breaker for an hour and still nothing. Luckily I had a replacement one I haven’t put in yet so I swapped it out. Not sure if this is something related to the freeze issues I was having, but I thought I would post just to be sure. How do I go about returning for a replacement?

@Eric_Inovelli - found this thread after I just purchased my first two Inovelli black switches for my SmartThings home setup. I just had both lock up in the same evening, likely the same time but not confirmed. This is the second time it’s happened to both switches. What is the current status? Are replacement switches being sent to affected customers or are you still diagnosing?

Great question and sorry for the issues. Right now we have a couple people using Zniffers (they monitor Z-Wave traffic) to see if we can capture some data. What I could do if it’s too much of a PITA, is send out replacements to see if it’s a switch issue or something on the network causing this?

I don’t mind zsniffers. LZW31. SmartThings v2 hub. I’ve IMd you directly

Did you message me or @EricM_Inovelli? I didn’t see any messages :frowning:

Yes. Added @Eric_Inovelli account just now in a response just in case. .

I’ll have to respond via Courtney – for some reason it’s not coming to my email. There should be a way to add someone (not via tagging, but actually via a button at the bottom). Either way, I’ll work via Courtney if you can’t find it as she sits in the office next to me.