Dual Blue Switches in 3 Way Mode - Only One Switch Works

I’ve been working on installing two Blue switches in the same 3 way circuit without having luck getting it working.

Starting with a dumb switch in the secondary slot using this diagram:

I confirmed that the primary blue switch and secondary dumb switch will work as expected when wired using this method. However, when I try to switch over to two blue switches using this diagram:

The primary blue switch will not turn on or off the lights, but it does show that it is powered and you can hear the relay click when switched. The secondary blue switch works as expected and can turn on and off the light without any issues.

I verified that both switches were in multi-switch mode however this did not change the behavior of the primary switch.

Does anyone have any insight into what the issue could possibly be? Not really sure what my next step should be troubleshooting wise.

Thanks for any insights!

Did you bind the two switches together?

2 Likes

Or if you don’t want to use binding, you can control the load switch via scenes.

In this configuration, the two conductors only provide power to the load switch. They do not facilitate communication between the two.

2 Likes

Are you referring to multi-way mode? Both switches are in Multi-Way (Toggle). I have not added the switches to home assistant yet, at this point I wanted to verify both were switching at the physical level prior to adopting them.

In order to use two blue series together like shown above, you have to bind the two (or more) switches in order for the alternate switch to send the turn on off dim commands.

Visit:

I’m not sure I agree with that based on the instructions. In the pre-setup section of the installation guide it states that you need to switch the switch to the correct wiring mode (which I have done). The final sentence of that section is:

Confirm that your switch works properly in the setup you desire and if so, move onto the next section: Hub/Gateway Setup.

My problem is that the switch does not work when configured, and it seems odd to me that you would have to attach both switches to a hub and bind them together in order for the basic switch to function. I would expect as a matter of good design that the physical switch would work regardless of a connection to a hub or other device. Are you saying that this isn’t the case?

If you want to use two Inovelli switches (Blues, Reds or Blacks) in a 3-way, then there are only 2 ways to make this work.

1 - Bind the two switches together
2 - Control the load switch via scenes

Using two Inovellis is different than using an Inovelli in a 3-way with either a dumb switch or an Aux switch. In those cases, the switches can communicate via a traveler wire or wires. However, two Inovelli switches cannot communicate via a traveler wire. They can only communicate via binding or scene commands.

The instructions are pretty clear if you refer to the proper part:

https://community.inovelli.com/docs?topic=10409

Multi-Way (w/2+ Smart Switches)

Please use this if you have two or more switches controlling one load (NOTE: Load may contain one or more light) and are using multiple Inovelli smart switches.

Neutral Wire Installation In this scenario, your switch is installed as a multi-way switch (which means multiple switches controlling one load) with two smart switches and you have a neutral wire present in the gang-box.

Please find the before picture (shown on the left) that best aligns with your wiring and then wire your switch per the schematic. If the schematics are too small to read, you can either turn your phone sideways (if on mobile) or click on the picture to make it bigger.

IMPORTANT: Please shut off power prior to installing your switch.

NOTES: There are a few things to note prior to installing your switch:

  • You will have to rewire your setup to a non-traditional way of wiring (we’re going to put 120V to each switch) so that the switch will work. Please take a picture of the before wires so that if you ever move and revert back to dumb switches, you remember what the wiring was like.
  • You must use an Inovelli switch in this setup
  • You must determine whether or not your hub/gateway supports Zigbee Binding (if not, the only other method is Zigbee Scene Control)

NOTE: If your hub/gateway does not support either Zigbee Binding or Zigbee Scene Control, you will not be able to wire two (2) or more smart switches together

However, If your hub supports either Zigbee Binding or Zigbee Scene Control, please move forward with the programming instructions after you wire the switches together per the schematics below:

3-Way Schematics Please see the below for if you have a 3-Way setup (ie: two switches to one load).

3 Likes

So only one switch has a load connected right? That switch is the only one operating the light correctly right?

I may have misread your post, but if the above is correct then yes, you need to include to the hub and then bind the switches. The switches do NOT recognize one another by the wiring.

3 Likes

Yes this is the case, and now that you explain it like this I can confirm that the lights are acting as expected. I will test that binding fixes the issue this evening and mark a solution.

I think my confusion over this whole issue comes from the way the instructions are written, which I would not consider to be as clear as @Bry suggests they are.

The lack of clarity to me comes from the binding comment being in the wiring schematics section. If you read step 5 of the install guide the last part of that instruction (after wiring schematics) states:

Once your switch is wired correctly, please restore power. If your switch is wired in a multi-way setup and/or you want the switch to be a dimmer, you must program your switch to work in the Pre-Programming section below. It will not work properly without programming it.

IMPORTANT: Once power is restored to your switch, you should see the LED bar pulsing blue – this means it is looking for a hub to pair to. If you want to quickly pair your switch, please put your hub in pairing mode. We recommend moving to the Pre-Programming section first to ensure your switch works properly before pairing.

In any technical manual I’ve ever used, the step on binding should be documented in step 5, with the wiring schematics link taking me to a page that only contains schematics. While I understand trying not to duplicate information, if zigbee binding is only pertinent to the blue switches putting that information in step 5 (rather than binding being found in the advanced setup section much later) makes much more sense. At the very least a referential note to binding for multi-way should be included to avoid the erroneous assumption (that I made) that after working through Pre-Setup both switches will operate as expected which again based on the documentation in Pre-Setup suggests that it would.

Hopefully that makes some sense; either way, thank you all for the help with this.

1 Like

Please let us know if the bindings work.

Also, that’s great feedback to send back to Inovelli to help clarify the instructions. I believe Eric mentions in the wiki pages how to send in feedback. It’s definitely worth sharing!

Well it’s been a couple days since the last update and I haven’t had any success with getting the switches to bind to each other. The instructions provided here don’t explain the process of binding just switches together, they seem to be related to smart bulbs in particular, which I do not have in my system. The current state of the system is that the hall switch setup to passthrough power to the other switch does not turn lights on or off, while the second switch will turn on/off the light. This is the same in Home Assistant as well.

At this point I’m not sure what to do outside of pulling one of the smart switches out of the circuit and replacing it with a dumb switch. Any insight would be appreciated.

The instructions here don’t have the zigbee binding steps for just switches, just:

Zigbee Binding Method
The below assumes you are not using a smart bulb, but rather you are wiring two (2) or more smart switches together.

DIRECTIONS COMING TONIGHT (OCT 24)

Are these directions listed somewhere else that you could refer me to for binding?

Unfortunately, I don’t think so. You are correct that the switch to bulb steps are documented, but not the switch to switch. I think what has happened that Inovelli started producing documentation for the Blues AND migrated support articles to a new platform at the same time, and some things are still pending.

Since you’re on Hubitat, @harjms can hopefully help further, although I’m not sure if he’s bound two switches together. Also, I would think that someone here on Hubitat has done that, so hopefully they can weigh in.

Are any/all of your switches in the affected group? This post describes the same issue and the OP wonders if because his/her switches are all in the affected group.

I haven’t bonded any switches yet. I do know you need the binding app.

You will need to load that into your apps code.

Then I thought it was fairly straight forward from there.

@adamkempenich

The binding driver and binding app are good tools to have but are not required for binding two Blue Series switches together. (you do need the binding app/driver for binding bulbs)

You can bind two Blue switches using the “Bind Initiator” and “Bind Target” features in the Hubitat device driver:

Click Bind Target on the slave switch then click Bind Initiator on the master switch

1 Like

Same boat here. After bouncing around through the (a bit cumbersome documentation) I landed on that same place holder:

DIRECTIONS COMING TONIGHT (OCT 24)

Can anyone point me in the right direction? I’m using home assistant (ZHA).
I did find this video but it is switch to bulb, not switch to switch:

@harjms @Bry

Thank you for the assistance, unfortunately I’m on Home Assistant not Hubitat, so I’m SOL with the methods provided above.

My current solution was to replace the switches with Aux Switches, and everything is currently working as expected. Not the ideal solution but given the lack of instructions for Home Assistant I’m not sure there was an easier fix available, and I’m not proficient enough to figure out what the correct method to fix would be.

As it stands I’m a bit more comfortable with Aux switches anyway since that allows both switches to function even if they’re not connected to Home Assistant (which I assume is what would happen if the switches were bound properly, but saves the config step which might be important for future owners if I sell this house).

@CodeMaster I wish I had a better answer for you, seems like we’re stuck in the same boat.

If you are interested in resuming your 2 x blues, my current understanding is that EP2 is used for controlling and EP1 is used for BEING controlled.

So if you bind EP2 from the source switch to EP1 of the destination switch for both ends of the 3-way (EP 2 of Switch A to EP1 of Switch B, and EP2 of Switch B to EP1 of Switch A), you should get 2 x blue working in a 3-way where they match each other in level and on/off control.

Edit: In 4+ way (3+ switches) it is probably better to group all of the EP1’s together then group EP2 from each switch to the group. This group could also include bulbs or other devices BEING controlled.

2 Likes

That is exactly how I set mine up and it works perfectly. Much better than similar setups with the Reds and Zwave Associations.

2 Likes