How to fix ground plate screw/ground plate on Blue Series

First off, I take no responsibility if you do damage to your switch with this fix.

I’ve been experiencing about a 10% chance of encountering a ground plate that won’t allow for normal closure around the ground wire. The plate looks like this with the screw out all the way. Note that the plate should normally go down and allow for clearance for the ground wire to fit in.

Initially, I was doing this:

After some tinkering I found the following to fix it in case it may be of help to others:

Step 1: Pop the front plate off. Be careful not to damage the fittings or the air gap switch.

Step 2: Remove the four screws to loosen the backing to the metal housing of the switch. Use a flat head screw driver to move the ground plate so that it is no longer stuck on the piece of plastic on the front side preventing it from coming down.

Step 3: Profit


I had the same problem with one of the 13 that I’ve installed so far. I used your first solution. Thanks for doing the work to find a better fix!

1 Like

Thanks for posting about this!
I’ve had this issue with 5 of the 11 switches I’ve installed so far. Before I saw this post, my “solution” was to loosen the screw most of the way and push hard to force the ground plate back to where it should be. :crossed_fingers: hopefully I didn’t break anything, those switches have been operating correctly so far.

1 Like

I was doing this at first. You have to unscrew hard enough that there is a little metal catch on the bottom of the screw that pops off. Figured this way out after doing that on two of the switches. Glad it was helpful!

1 Like

I wound up using your first solution for many of my switches too. Strange issue, but not the end of the world :slight_smile:

1 Like

Hey @bgreet - thanks so much for posting this! Very helpful :slight_smile:

Part of my responsibility with these devices is to make sure they’re constantly improved on from both a firmware and hardware side. In addition, I need to improve the instructions so people can be on the lookout for issues like this.

You mentioned you have seen this on a out 10% of your switches (very concerning to me) and it seems this is something that others are experiencing too based on the responses, so I’d like to understand this more if you don’t mind.

@bryan, @salscode and @finder39 - can you guys chime in too?

My questions are as follows:

  • Are you using a screwdriver to loosen the screw or an impact driver?
  • When you are loosening it, are you met with any resistance from the screw? How it should behave is that it should be easy to loosen it, but when it’s near the end of the ability to loosen further (before the plate pops off), it’s supposed to give you a bit of resistance.

I want to also be clear that I’m not trying to point fingers here. I’m trying to understand if it’s a defect or if it’s something that I need to do a better job at explaining in the instructions. Oftentimes, I forget to put myself in someone’s shoes who hasn’t installed 100’s of these. I try my best, but there’s always room for improvement.

I’ve definitely popped the ground screw out myself in the past!

Hey Eric, thanks for the reply.

  1. I’m using a screw driver.
  2. The issue is not necessarily the screw but the ground plate itself. It’s stuck and won’t come down to accommodate a wire through it. In that first picture that is the lowest the ground plate will go with the screw maximally counter clocked and you’ll see that the screw just goes up instead after counter clocking. Normally the ground plate should come down and you should be able to see through the two holes without the ground plate in there when it drops as its supposed to. There were two different screw colors that I’ve seen with the switches and in my experience it seems to involve the screw color that is pictured. It honestly would be easier if we could pop the ground screw out for repositioning after taking the faceplate off but there seems to be a metal catch now on the screw that prevents the ground screw from detaching from the ground plate.

The non effected switches have a ground plate that lowers without difficulty or catching on anything after counter clocking the screw.

Hey @Eric_Inovelli,
For me, this happens in about a third of the Blue switches and none of the Aux switches I’ve installed so far. To make a video for you, I grabbed a boxed switch at random and it had the issue.

  1. I use a screwdriver.
  2. The screw loosens easily (with a normal amount of force needed), but the plate stays firmly in place. Even pushing on the screw doesn’t move the plate to the correct position unless you put a large amount of force (which is how I’ve been resolving this issue so far).

The resistance at the end (to prevent the plate from popping off) is definitely there, but that doesn’t seem relevant to this issue.


Exactly the same response as the others. I’m at 2 of 22 with the issue, so about 10% here as well.

  1. Using a normal screwdriver.
  2. Screw works like a screw should but the plate position is fixed, therefore the screw moves up instead of the plate moving down.
1 Like

I am using an electric screwdriver to loosen and tighten all screws on my switches. There was no resistance, it unscrews normally but the little metal plate inside doesn’t move at all.

1 Like

I recently received some replacement switch. So far I have installed 4 of them, and 2 of them would not open the ground correctly. All my first round of switch (20 of them) opened correctly. I believe the little metal disk is catching on the plastic inside the switch. I was able to fix one of them (the only one I tried so far) by taking the ground screw completely out, flipping the disk around 180 degrees and then put the screw back in.

Geez, this sounds like a major issue. I’ll get the manufacturer on it. Thank you @salscode for the video, that’s incredibly helpful.

When you turned it 180 degrees, did you also flip it at all?

I didn’t flip it. There are little traction grooves on the plate that I figured should be facing the ground wire.

On the second switch, I pulled the plastic switch piece off, loosened the 4 faceplate screws, jiggle the ground screw around and the plate came loose to function correctly. I put it all back together and it seemed fine. I went through the rest of my switches and found for more with the same issue.

1 Like

Looks to my untrained eye that maybe they are tightening the ground screw before putting the metal faceplate onto the plastic housing and the ground plate is getting stuck. If they didn’t tighten the ground screw completely down, it might not get stuck or they could at least easily see if it’s in the correct spot.

On a side note, what’s the little pad under the switch? I’m assuming it’s an antenna on a pad to separate from the metal a little. It doesn’t seem to be so stuck down very well. I had one that was off it’s perch and was stuck down on on the metal to the side. I pulled it off and restuck it to the right spot.

1 Like


10/10 on switches with the antenna issue. Replacements arrived and the first three I installed all had this same ground screw issue. QC on these is seriously lacking.

4 of 9 replacement switches I got have this issue. Particularly it seems to happen with all the switches that have a darker less shiny ground screw. Left side is problem screw.


Hey @Eric_Inovelli

I attempted to do this on a few switches. When I have the 4 screws, that hold the housing on, loosened, the ground pinch plate is free and loose as it should be. But as soon as I screw back in the 4 screws the issue happens again. This doesn’t seem to be a full home run solution unfortunately.


After unscrewing the four screws and loosening the ground plate, maximally unscrew the ground screw. When you are screwing the 4 screws on the back apply pressure to the ground screw and that should hopefully keep the plate down.

1 Like

hmmm that actually kind of worked! It’s still a little janky and gets stuck when screwing outward but now it can actually clamp around a wire. thank for your time

edit: caveat is if i ever need to unscrew the ground wire and rescrew it again, i have to do these steps all over again. argh…

1 Like